
 
Addendum to ARC Plus and AutoPilot Plus  

Installation and Operation Manuals 
 

AutoPilot Plus Updates 
 
Real-Time Charts (New in 2.0) 
 
Real-time charts display in AutoPilot Plus custom views to allow quick data analysis and 
comparison for one or more analog metering channels.  
 
To create a chart:  
 

1. Launch the custom view editor by selecting File > New… > Custom View. To 
add a chart to an existing custom view, right-click the custom view in the 
Navigator and selected Edit View.  

2. After the custom view editor opens, find the Chart component in the toolbox. 
Drag it into the workspace.  

 
To customize chart properties: 
 

1. Select the chart in the workspace to populate the Properties fields. (Select View > 
Properties if properties are not already visible).  

2. In the Data properties category, click in the Chart Lines field and then click the 
[…] icon to select metering channels for display within the chart. Note that each 
metering channel can be assigned to the left or right Y-axis. Two Y-axes allows 
comparing multiple channels when scales are different.  

3. Y-axis values will be calculated automatically. To set axes manually, go to the 
Chart Axis properties for the left or right Y-axis and turn Auto Scale off. 

4. Adjust color, label, font and other characteristics using the remaining property 
fields. Explanations for each property appear at the bottom of the Properties 
window.   

 
Log Viewer (New in 2.0) 
 
The Log Viewer provides a way to review logging data at-a-glance, without creating a 
new report. Select View > Log Viewer to display this window. The log viewer docks 
alongside the alarms and events tabs, and may be collapsed or fixed permanently to the 
display area.   
 
Embedded Web Pages in Custom Views (New in 2.0) 
 
Browser-based dashboards and configuration utilities have become ubiquitous and it is 
now possible to access web pages directly from AutoPilot Plus. The Web Page custom 
view control drops in to any custom view to give operators browser access without 
leaving the AutoPilot environment. 
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With the custom view editor open, click and drag the Web Page component into the 
workspace. In the Properties area, enter the URL to display in the custom view. If you 
wish to lock down the display to the specified URL only, set the Enable Navigation 
property to false. This will make it impossible to navigate away from the URL.  
 
Redesigned Reports Engine (New in 2.0) 
 
The AutoPilot Plus reports engine is completely redesigned for optimized performance in 
version 2.0. Reports are now generated and previewed within AutoPilot Plus. The steps to 
create report templates, save them and to view the finished reports remain the same.  
 
Automatic Report Emailing (New In 1.4.7) 
 
If you prefer to receive logging reports via email instead of or in addition to sending them 
to the printer, AutoPilot Plus now has the ability to automatically email reports in PDF 
format. Set up the report as usual by selecting New > Report from the File menu. On the 
last screen of the report wizard, check the box marked Email a PDF copy of this report 
and select the desired schedule to receive the report. If you also use automatic report 
printing, the email and print schedules will be the same. Note that the reports are emailed 
automatically, on the user defined schedule. To view a report on-demand, print the report 
using the local printer.  

 
Option to Take Log on Alarm (New In 1.4.7) 
 
To facilitate detailed analysis of alarm conditions, AutoPilot now has an option take a log 
when an alarm occurs. To set this up: 
 
Go to Tools > Options and find the Logging tab. Use the check boxes to determine 
whether AutoPilot should log warning alarms, critical alarms, or both. Then select the 
amount of time AutoPilot should wait after the alarm before taking the log.  
 
Load Custom View on Startup (New In 1.4.7) 
 
AutoPilot Plus can load a custom view when the application first loads, bypassing the 
default view. This is useful if the primary operator interface is managed by custom views. 
 
To configure a custom view to load on startup: 
 

1. Go to Tools > Options and open the Navigator tab.  
2. Check the box marked Open a custom view on startup and click the […] button 

to browse to the desired custom view file. Click OK in the file selection dialog. 
3. Click OK to close the Options dialog.  

 
AutoPilot Plus will then open the custom view each time you run the application..  
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Copy/Paste Images from Other Applications into a Custom View (New In 1.4.7) 
 
To provide an easy way to integrate your own images in custom views, AutoPilot 
supports cutting and pasting graphics from other applications directly into the custom 
view editor. For example, you can find a logo on your station’s web site, copy it to the 
Windows clipboard, and paste it into the custom view editor.  
 
Note that the Ctrl-C and Ctrl-V shortcuts work in most applications, but you must use the 
right-click context menu to copy images from an Internet Explorer window. 
 
Undo Capability in Custom Views (New In 1.4.7) 
 
Creating and editing custom views is now easier with “Undo” and “Redo” features. To 
view a history of editing changes in the custom view editor, select Undo history from the 
View menu. Double click an edit to restore the custom view to its condition prior to 
making that edit. This will also gray out affected edits in the undo history window. 
Double click a grayed out entry to replace edits that you deleted by mistake. You can also 
use the Ctrl-Z shortcut to undo a change, and Ctrl-Y to redo it. Up to 100 edits are stored 
in the undo history window.  
 
Click Actions Open Custom Views in a New Window (New In 1.4.7) 
 
When using a custom view click action to navigate to a new custom view, you now have 
the option to open that view in a new window. This is similar to opening a hyperlink in a 
new window while web browsing. To create a custom view component that “links” to a 
new custom view when the operator clicks on it: 
 

1. Click on the component in the custom view editor.  
2. Open the properties window and edit the CommandAdaptor property in the 

custom view editor. The Command Adaptor dialog allows you to choose the type 
of action to occur. Choose “Navigate (New Window)” to cause the component to 
open a new custom view in a separate window.  

3. Select the custom view to which this component should link. 
 
New Control for Custom View Map Images (New In 1.4.7) 
 
Adding U.S. and state maps to custom views is now easier with a new map control in the 
custom view editor.  To add a map to your custom view, click on the Map component in 
the toolbox and drag it into the custom view canvas. Then open the properties window 
and under the Map property, choose which map to use. This will place the desired map 
image in your custom view and allow you to resize as desired.  
 
Trend Arrow Shows Metering Channels Trends (New In 1.4.7) 
 
A new custom view component called the Trend Arrow can be added to a custom view 
(typically next to an existing meter component) to indicate whether the value is generally 
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increasing or decreasing over a user-defined interval. To add this component to a custom 
view, click and drag the Trend Arrow component into the canvas. Select the display 
properties as usual, including the colors to show increasing, decreasing or neutral (non-
changing) values. Then choose the sampling period, which determines how many 
seconds AutoPilot allows between each trend calculation.  
 
Web Picture Allows Dynamic Graphic Integration (New In 1.4.7) 
 
The Web Picture custom view control works by downloading an image from a URL and 
updating the image at a user-defined interval. To add a web picture to the custom view, 
drag and drop the web picture component into the custom view canvas. In the URL 
property, enter the address where the web image is located. If the web site requires login 
credentials enter them in them in the User name and password fields.  
 
Weather Map Control Shows Real-Time Weather Radar (New In 1.4.7) 
 
While the standard Map control allows map-based displays, the Weather Map control 
allows you to overlay status indicators on a dynamically updated weather radar image 
from the NWS. To add a weather map to your custom view: 
 

1. Drag and drop the Weather map component into the custom view. 
2. In the component properties window, select whether radar image should display 

static or looping 
3. Determine the refresh rate of the image  
4. Select the region of the country to display 
5. Resize the map as desired 

 
Camera Picture Control Allows Security Camera Monitoring (New In 1.4.7) 
 
AutoPilot Plus is now compatible with a line of Panasonic IP-based security cameras to 
allow live camera images to be added to custom views. After installing one of the camera 
models below, you can view regularly updated images in custom views by following 
these steps: 
 

1. Drag and drop the Camera Picture component into the custom view. 
2. In the Properties window, enter the User name and password for the security 

camera. 
3. Choose a refresh rate for the camera image. Note that the camera also has a user-

defined refresh rate which determines how often the camera refreshes the image. 
The refresh setting in AutoPilot Plus determines how often AutoPilot Plus 
downloads the camera image.  

 
The Panasonic camera models currently supported are: 
 

• BB-HCM series 
• BL-C series 

 4



• BB-HCS 
• KX-HCM110 
• KX-HCM280A 
• BB-HCE 

 
New Power Monitoring Capabilities in Custom Views (New In 1.4.7)  
 
A new custom view control in the “Specialized” category allows AutoPilot Plus to 
calculate power values when the ARC Plus is connected to a Bird TPM  power monitor.  
 
To add power values to a custom view: 
 

1. Start with the Bird TPM power monitor connected to the ARC Plus with 
calibrated forward and reflected power readings.  

2. Open the custom view editor and drag the Bird power monitor component from 
the toolbox into designer.  

3. In the Properties workspace,  find the Forward Power Adaptor and Reflected 
Power Adaptor settings in the Meters section. Click in these fields to determine 
the channel AutoPilot Plus will read for forward and reflected power, 
respectively. Note that the right-click context menu is not used for binding power 
monitor channels.  

4. Next, customize the scale and colors of the forward power meter by entering 
lower and upper limits and colors for each range of values in the Forward Power 
Limits section. This only affects the meter’s appearance in AutoPilot Plus; alarm 
behavior is configured using AutoLoad Plus.  

5. Finally, go to the Meters section and set the critical and warning VSWR levels, 
max and min forward power, and power units.  

6. To preview how the control will look at various forward and reflected power 
levels, enter nominal values for the Forward Power and Reflected Power 
settings.  

 
AutoPilot Plus Runs in Full Screen Mode (New In 1.4.7) 
 
It is now possible to run AutoPilot Plus in full screen mode to hide AutoPilot Plus 
toolbars. This is ideal to provide operators with monitoring and control access via custom 
views while hiding program functionality. To run AutoPilot Plus in full screen mode, 
press F11 or select Full screen from the View menu.  
 

ARC Plus Firmware Updates 
 
New Macro Commands (New in 2.0) 
 
ARC Plus firmware version 2.0 features three new macro commands: 
 
Set Limit allows a macro to change meter limits, which is ideal for use in conjunction 
with macros that automatically set day/night AM power levels. 
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If Calendar Time allows a macro to reference the onboard calendar. This provides a way 
for the macro to take action based on sunrise/sunset times, or a user-defined calendar 
time.  
 
Speak Phrase causes the ESI Plus to output a phrase, which will be heard during a 
telephone session or via output audio when the ESI input/output jack is selected for audio 
output. To output audio to the external jack, remove the top cover of the ARC Plus and 
move the 2-pin jumper at P5 to connect the center and right pins. This allows building 
annunciation systems to connect to the ESI Plus, with status conditions announced using 
the Speak Phrase macro command. This mode overrides the audio input function, which 
is achieved by connecting the center and left pins at P5.  
 
Override Command Channels (New in 2.0) 
 
Unused command channels can now be replaced with macros, allowing easier front 
panel, AutoPilot Plus, ESI Plus, and Web Interface access to macros. To override a 
command channel, open AutoLoad Plus, connect to the site, and select the Commands 
tab. Click in the Override field associated with the desired channel and select a macro to 
use in place of the raise and lower outputs. After you save your changes, the raise 
command for this channel will start the selected macro, and the lower command will stop 
it. Note that you do not need to have an ICRU for the associated command channel. In a 
16-channel system, for example, you can override channels 17-256 without giving up use 
of any relays.  
 
SNTP Compatibility (New in 2.0) 
 
The ARC Plus can now synchronize time with an NTP/SNTP server. To configure SNTP 
settings, select Time Settings from the Edit menu and navigate to the SNTP tab. Enter 
the IP address and port for the SNTP server, and set the synchronization interval.  
 
Using Macros to Mute Metering and Status Channels (New in 1.1.1.21) 
 
ARC Plus macros have a new “set mute” function which allows you to program macros 
to mute metering or status channels so that alarms will not be reported. Use the “set 
mute” function as you would any other macro command, but selecting the Set Mute 
function from the list of macro commands in AutoLoad Plus.  
 

AutoLoad Plus Updates 
 
Site List Editor (New in 1.2) 
 
To allow direct editing of an ARC Plus unit’s site list, AutoLoad Plus now has a Site List 
Editor, accessible in AutoLoad Plus by going to Edit > Advanced… The ARC Plus will 
automatically detect changes in the ARC Plus network, so you should not need this tool 
except for troubleshooting purposes.  
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Hide/Unhide Blocks of Channels (New in 1.2) 
 
By default, all 256 ARC Plus channels are displayed on the front panel of the ARC Plus. 
To hide channels from display on the front panel, go to the hidden channels tab in 
AutoLoad Plus and click on the checkboxes for the channels you would like hidden. If 
you have a block of channels you would like to hide (i.e. 17-256), go to Edit > Hidden 
Channels for a shortcut. Entire the desired channel range, choose whether to hide or 
unhide these channels, and click OK.  


