AutoLoad GSC

Instruction Manual

B TECHNOLOGY




Table of Contents

INEFOAUCTION ..ttt bt a ettt h e e ettt e bt e s bt e et e bt et e e en e r e nree 2
ConNecting tO YOUr EQUIPMENT ..ottt e e e e 4
Monitoring and Controlling YOUr SySte@m ...........ooiiiiiiii e 6
CONFIGUIING YOUE SYSTEOM ...ttt ettt e ettt b e e e n e 7
CalIDIATION L.t 22
WOTKING OFFlING ...ttt et et e et et esee e ene e e e e nneeeneeenteennee s anees 23
Save and Restore System ConfigUIation .........coeoiuiiiiiiiii e 24
PrINTING e 26
Firmware and Unit NUMDEIS ......ooo ettt e e et e e e e e e e eneee e e 27
Setting the System Password ..o 29
(O] o} o o -3 PSP P RO PP 30
Appendix A — SEttING @N ACTION. .....oiiuii i 34

Copyright © 2011 Burk Technology, Inc.

7 Beaver Brook Rd
Littleton, MA 01460
978-486-0086
www.burk.com

Rev A



Introduction

AutolLoad GSC is the configuration and real-time monitoring and control software for the GSC3000 and
VRC2500. AutoLoad GSC allows you to do the following:

e Connect to your equipment

e Monitor and control your system

e Configure your system

e Calibrate GSC/VRC meter channels

e Work with system configuration offline

e Save and restore system configuration

e Print system configuration

e Upload firmware and assign unit numbers
e Setthe system password

AutoLoad GSC requires version 5 firmware.

Note: for multi-site monitoring and control, logging, and more power features, use AutoPilot® 2010. See
www.burk.com for more information.

Welcome Screen
When AutolLoad GSC starts, it will display the welcome screen. From here you can choose to connect to
a site, open an archive file, work offline, or exit the program.

@ Autoload GSC [

autoload

GSC/VRC

Connect to a site
O pen an archive file
‘work offline

E

AutoLoad GSC welcome screen

Note: If desired, you may disable the welcome screen from the options dialog.



Screen Layout
There are two areas of the main window: the unit list (on the left) and the tab area (on the right). The
unit list shows all of the units on your system's GBus. The tab area shows tabs for the monitor/control

and configuration options for the selected unit. Click on a unit in the unit list to load its tabs into the tab
area.
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AutoLoad GSC main window

Note: Only tabs applicable to the selected unit will appear in the tab area.

Getting Help

For assistance with AutoLoad GSC, please visit www.burk.com or contact Burk Technology Customer
Support by email at support@burk.com or by calling 978-486-3711.



Connecting to Your Equipment
To connect to a site, choose "Connect to a site" from the welcome screen, or click "Connect..." from the
File menu.

Connect to Site ﬁ

@ COMport () Dialup & TCPIP
COM port: [[;omg -
Password: (I ITT ]

Save password

oK) (oo

Connect to Site dialog

Connection Methods
AutolLoad GSC supports three types of connections:

e (COMport
e Dialup
e TCP/IP (including the GSC/VRC Web Interface)

Depending on which type of connection you are using, enter the correct settings for your equipment
(see below). Enter your user or system password, and check the "Save password" box if you want
AutoLoad GSC to remember your password for the next time you connect.

Important Notes:

e The default password is PASSWORD.
e Passwords are not case-sensitive.

COM Port

COM port
Select the COM port on your computer that you want to use.

Dialup

Modem
Select the modem on your computer that you want to use.



Phone number
Enter the phone number for your GSC/VRC site.

TCP/IP

IP/Host Name
Enter the IP address or host name of your GSC/VRC site.

Port
Enter the port number used for your GSC/VRC site. The default port number for a GSC/VRC Web
Interface is 4095.

Note: By default, AutoLoad GSC will automatically "tune" the timeout and retry settings for your
connection. If desired, you may enter these settings manually using the options dialog. Using the

automatic settings feature is strongly recommended.

Cached Configuration

AutolLoad GSC will store a copy of your site configuration in its cache. When connecting to your site,
AutoLoad GSC will only download configuration files that differ from the cached files. This greatly
speeds up the connection process.

If desired, you may delete files from the cache directory on your computer to force AutoLoad GSC to
download all of your site's data. The cache directory for AutoLoad GSC is located here:

%AllUsersProfile%\Burk Technology\AutoLoad GSC\Cache



Monitoring and Controlling Your System

AutolLoad GSCincludes a simple interface for real-time monitoring and control of the GSC/VRC system.
This feature is available on the "Monitor" tab, available for all types of I/O and G-Link units when
AutolLoad GSCis connected to the site.
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Monitor tab

The monitor tab is divided into five sections:

Metering
The meter section displays real-time values for all meter channels on the selected unit.

Status
The status section displays real-time values for all status channels on the selected unit.

Commands
The commands section displays command buttons for all the command channels on the selected unit.

Macros
The macros section displays the status of each macro on the selected unit. Use the run () and stop ()
buttons to run and stop a macro.

Alarms
The alarms list (appearing on the bottom of the screen) displays all current alarms on the selected unit.
Use the clear alarms () button in the tool bar to clear alarms.

Note: For more powerful monitoring and control options, use AutoPilot® 2010. See www.burk.com for
more information.



Configuring Your System

System configuration is divided into a number of functional groups, each with its own tab in the main
window. When you select a unit in AutoLoad GSC, the program will automatically load the tabs for that
unit. Note that not all tabs are available for all units. AutoLoad GSC will only load tabs that are
applicable to the unit you have selected.

Configuration Tabs
The following configuration tabs are available in AutoLoad GSC:

e Meters

e Status

e Commands

e Display Settings
e Macros

e Muting

e Timed Events

e Users

e Dialout Settings
e Voice Settings
e Phone Lists

o Selective Alarm Dialout

Renaming Units
The only configuration option not included on one of the above tabs is the unit's name. The unit name
helps an operator identify a unit on the G-Bus.

To set a unit's name, click on its label (not its icon) in the unit list. The list will then allow you to edit the
name, just as you would rename a file in Windows.

Note: Be sure to save your changes after changing the unit name.



Meters

The meters tab allows you to configure meter labels, calibration, and limits. The meters tab is divided
into two grids. The top grid displays labels and calibration settings. The bottom grid displays limits (and
their associated settings) for the channel that you have selected in the top grid.
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Meters tab

Top Grid
The following settings are available on the top grid:

#
Displays the channel number.

Name
Enter a name to describe this channel.

Units

Enter the units label appropriate for this channel. If desired, select a pre-defined label from the drop
down list. If you choose a label from the list, the Voice Interface will announce the full term for the label
instead of its abbreviation (i.e., "decibels" instead of "dB").

Type
Select the meter type for this channel (o to 10, -5 to +5, linear to power, indirect power). The meter type
affects how calibration works for this channel.

Bottom Grid

The following settings are available on the bottom grid:

Limit

Displays the limit you are configuring for this row. There are two lower limits and two upper limits.



Value
Enter the value for this limit.

Alarm
Select the alarm severity for this limit (warning or critical), or select "none" if this limit should not cause
an alarm. Note that only critical alarms will cause the system to dial out.

Delay

Enter the alarm delay for this limit. If this limit is configured to alarm, the system will delay the alarm by
this duration to prevent temporary fluctuations from causing false alarms. Specify the delay in seconds,
between o and 25.5.

Action
Specify what action (if any) the system should take when this limit is crossed.

Status
The status tab allows you to configure status labels, alarms, and input types for the selected unit.
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Status tab

The following settings are available for each status channel:

#
Displays the channel number.

Type
Select the input type for this status channel (pull up or pull down).



The following settings are available for both Low and High conditions (indicated in the top row of the grid
header):

Label
Enter the label or message associated with this status condition. This label is used to display this
condition in software, announce it over the Voice Interface, and to indicate state in alarms.

Alarm
If this status condition should cause an alarm, select the desired alarm severity (warning or critical), or
select "none" if no alarm is desired. Note that only critical alarms will cause the system to dial out.

Action

Specify what action (if any) the system should take when this condition occurs.

Commands

The commands tab allows you to specify how command channels should operate and appear onscreen.
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Commands tab

The following settings are available for each command channel:

#
Displays the channel number.

Mode
Select the operation mode for this channel (momentary or latching).
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Duration
For momentary channels, enter the duration (in seconds) for which this command should remain
activated. The duration ranges from 0.1 to 25.5 seconds.

(A) Label
Enter the label for the "A" relay.

(B) Label
Enter the label for the "B" relay.

Display Settings
The display settings tab allows you to configure status and meter limit colors, and meter decimal
precision.
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Display Settings tab

The following settings are available for each channel:

#
Displays the channel number (for both meter and status channels).

The following settings are for status channels:

Low
Select the color you want to display onscreen for a status low condition.

High
Select the color you want to display onscreen for a status high condition.
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The following settings are for meter channels:

2nd Lower
Select the color you want to display onscreen when a meter is below the second lower limit.

ist Lower
Select the color you want to display onscreen when a meter is below the first lower limit.

Normal
Select the color you want to display onscreen when a meter is in its normal range.

ast Upper
Select the color you want to display onscreen when a meter is above the first upper limit.

2nd Upper
Select the color you want to display onscreen when a meter is above the second upper limit.

Macros

Note: This information will help you use the AutoLoad GSC macro editor. For information on writing
macros, please see the GSC3000/VRC2500 Installation and Operation Manual, available online at
www.burk.com.

The macros tab allows you to create and edit the macros on the selected unit. There are three areas in
the macros tab:

Macro drop down (top)
Use the macro drop down to select the macro number that you want to create or edit.

Macro editor (middle)
The macro editor is where the source for the select macro appears. This is where you enter new macro
code, or edit existing code.

Syntax help (bottom)

The syntax help area at the bottom of the screen displays a description of what the currently selected
macro keyword does, and how to use it. Help text will only appear in this area when a macro keyword is
selected in the editor. You will see this area update as you type macro code.
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Macros tab

Macro Editor Features
Note: You can enable/disable the following features using the Options dialog.

Syntax Help
Syntax help appears at the bottom of the screen. This information applies to the term that is currently

selected with the cursor in the macro editor.

STATUS
Returns HIGH (1) or LOW (0) for status %'
STATUS (x)

Syntax Help
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Syntax Suggestions

As you type, the macro editor will show a popup below the cursor containing the keywords that appear
to match what you are typing. You can use this popup when you are unsure of what commands are
available, or what the exact wording of a command is. Click on an item in the list to replace the
currently selected text in the macro with that term. You can also simply press the spacebar to use the
selected term. This can greatly increase your speed when entering macro code.

Automatic Error Checking

By default, the macro editor will automatically check for errors as you type. If code coloring is enabled
(see below), errors will appear highlighted in yellow. When your macro code contains an error, the
macro editor will display an explanation of the error in the syntax help area at the bottom of the screen

(see above).

p=TER

METERAD

METERCC

METERF

METEROFF

METERON

MINUTE E
MONTH
MUTEMETER
MUTESTATEMETER
MUTESTATESTATU

MUTESTATUS
N

Syntax suggestions popup

Missing THEN after IF statemert. |

Macro error explanation
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Code Coloring
By default, the macro editor will display your macro code in color. The macro editor uses multiple colors
to identify the purpose of a term or value in your code. The following types of data are color coded:

e Keywords (blue)

e Variables (purple)

e Constants (teal)

e Strings (maroon)

e Syntaxerrors (yellow highlight)

MACRO "Powerup"”
L=1

WHILE & < 10 AND STATUS(1) = LOW
cocHMMaND ME, ME, 14

L=L4+1

WEND
IF S5TATUS(1) = LCOW THEN
ALLAR "Powerup Failed™
ENDIF
MEND

Example of macro code shown in color

Timed Events
The timed events tab allows you to schedule actions to occur at specific times/intervals.
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Timed events tab
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To add a new timed event, first configure the schedule by clicking the [...] button from the "Time"
column.

Date
(e ]
9 Every day Cancel
Epecific weekday
Specific day of the month Advanced > |
Menth: Every Morth =
T
Every hour at murntes. past the how
Every fnuté
Evary sacond
9 Atexacty 120000 AM =2

Time (schedule) popup

The following options are available for the schedule:

Date
You can schedule the event to occur:

e Everyday
e Weekly on a certain weekday
e Monthly on a certain day of the month

For any of the above options, you can configure the event to run only during a certain month, or during
any month.

Time
You can schedule the time of day when the event happens as follows:

e Every hour (at a specific number of minutes past the hour)
e Every minute

e Everysecond

e Ata specifictime

Note: If the above options do not suit your needs, you may click the "Advanced >>" button to manually
specify the day of week, day of month, month, hour, minute, and second.

Action
To specify what action the system should take when the correct time occurs, click the [...] button in the
Action column.

16



Moving and Deleting Timed Events
To move a timed event up or down in the list, use the up ( «) and down (=) buttons.

To remove a timed event, use the delete (%) button.

Users
The users tab allows you to create and edit accounts for up to 32 users.
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Users tab

The following fields are available:

#
Displays the user number (1—32).

User Name
The name of this user. Note that this is for display purposes only, and is not used when logging on.

Password
The password for this account. The password, up to eight characters long, may include letters and

numbers. When logging on to the Voice Interface, use the number on the keypad that corresponds to
the appropriate letter.

Access Level

Select from the three access levels: System, Operator, and Observer. System accounts have complete
control of the system, including configuration. Operator accounts are restricted from configuration, but
can issue commands. Observer accounts are read-only.

17



Dialout Settings
The dialout settings tab allows you to configure up to five phone numbers that the system will dial
when an alarm occurs.
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Dialout settings tab

The following fields are available:

Initialization String
This is the initialization string the unit will use to initialize the attached modem.

#
Displays the phone number entry position.

Phone Number
Enter the phone number that the system will dial.

Mode
Select the type of call you want the system to make: Data, Pager, or Voice. (Voice is only available on
the Voice Interface).

Attempts
Enter the number of times that you want the system to attempt to call this number to report an alarm.

When to Call

Select the days during the week when you want the system to dial this number on alarm (Always,
Weekdays, Weekends, Every Day). Note that if you select "Always", the system will not use the Start
and End times (below).

Start
Enter the starting time of the period of time during which you want this phone number to be available
for dialout.
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End
Enter the ending time of the period of time during which you want this phone number to be available
for dialout.

Voice Settings
The voice settings tab allows you to configure the Voice Interface's voice settings, as well as some of its
prompts.
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Voice settings tab

The following fields are available:

Personality
Select the desired voice "personality".

Volume
Adjust the voice volume up or down.

Pitch
Select the desired pitch profile for the voice.

Speed
Adjust the speed of the voice faster or slower.

Audio Input Timeout
Set the duration of time for which the Voice Interface will play microphone or input audio.

Command Escape Delay
Set the length of the delay for which the Voice Interface will wait before executing a command. This
delay allows you to cancel an erroneous command.
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Inactivity Timeout
If no DTMF commands are sent to the Voice Interface before the inactivity timeout expires, the unit will
disconnect from the call.

Rings
Set the number of rings after which the Voice Interface will answer a call.

Welcome Message
Enter the phrase that the unit will speak when it answers the phone.

Goodbye Message
Enter the phrase that the unit will speak when it receives the command to end the call.

Phone Lists

The phone lists tab allows you to create additional dialout lists that the Voice Interface can use when
calling out for an alarm.
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Phone lists tab

The phone lists tab allows you to create four phone lists, each with five numbers.
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Selective Alarm Dialout
The selective alarm dialout tab allows you to specify what phone list each alarm condition will dial. Note
that the primary phone list (configured in dialout settings) is always dialed.
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Selective alarm dialout tab

Use the following fields to configure selective alarm dialout:

Unit
Select the unit number for which you want to configure selective alarm dialout.

Meter Channel
Displays the meter channel number/label.

[Meter] Dialout List
Select the phone list number that you want this meter channel to use.

Status Channel
Displays the status channel number/label.

[Status] Dialout List
Select the phone list number that you want this status channel to use.
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Calibration

To calibrate your meter channels, follow the steps outlined below:

Open the meters tab.
Select the desired meter from the list.
Click the "Calibrate..." menu item from the Tools menu.

S~ W oN R

Enter the correct value for the channel in the "Set new value" field (recommended).
—Or—
Select "Set constant" and manually enter the desired calibration constant.

5. Click "Calibrate" to apply your new settings.

Calibration @'i_hj
Channel 4
Value (live): 0
% full scale
i@ Setnew value: =
i) Set constant: 0002442 |
LCalibrate ] [ Close

Calibration dialog

Note: The [x]% full scale indicator gauges calibration accuracy. A larger value means that the margin for
error is smaller (the channel will be more accurate).
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Working Offline

Using AutoLoad GSC, you may edit site configuration without being connected to your site equipment.
This is often useful when preparing for equipment installation ahead of time.

To work offline, you can choose "Work offline" from the welcome screen, or use the "Offline
Configuration" sub-menu on the File menu.

Note: When working offline, you are working with a single unit only. You can work offline with any type of
unit.
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Save and Restore System Configuration

A Saving, loading, and reverting affect the selected unit only. If you are
- working with more than one unit, be sure to take appropriate action on
each unit as necessary.

Saving

== Saving to the Unit
To save/upload your changes to the selected unit, use the "Save to Unit" menu item from the File menu.
AutoLoad GSC will upload only the configuration files that have changed.

Note: Depending on how many changes you have made, and the speed of your connection, this process
may take up to several minutes.

& Saving to an Archive File

To save a copy of your configuration on your computer, use the "Save to Archive File" menu item from
the File menu.

/ ' E Saving to an archive file does not affect your GSC/VRC unit.

Auto Save

AutolLoad GSCincludes an auto save feature that will automatically save a copy of your configuration
on your computer. This feature can be enabled/disabled, and offers several options to control how
often it saves your changes. You can configure these options in the Options dialog.

AutolLoad GSC automatically saves your configuration to the following location:
%A11UsersProfile’%\Burk Technology\AutoLoad GSC\AutoSave
®Reverting

Reverting changes will cause AutolLoad to discard any changes you have made since you connected to
your site or last uploaded.

Reverting All Changes
To revert changes for all configuration tabs on the selected unit, use the "Revert" menu item on from
the File menu.
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Reverting a Single Tab
To revert changes for the currently selected configuration tab, use the "Revert" menu item from the
"Selected Tab" sub-menu in the File menu.

[ Load from File

Loading configuration from an archive file will restore your unit's configuration to use the settings
stored in that file.

Note: You can restore from an archive file created from a different unit, as long as the file was created from
the same type of unit.

Loading All Unit Configuration
To load data from an archive file into all of the configuration tabs on the selected unit, use the "Open
Archive File..." menu item from the File menu.

Loading a Single Tab
To load data from an archive file into the currently selected configuration tab, use the "Load from
Archive File..." menu item from the "Selected Tab" sub-menu in the File menu.

Restoring Defaults
Storing defaults allows you to restore some or all of your unit's configuration to the factory default
settings. This is primarily useful for preparing an existing unit for use in a new installation.

Resetting All Unit Configuration
To restore default settings for all configuration tabs on the selected unit, use the "Set to Default Values"
menu item from the File menu.

Resetting a Single Tab
To restore default settings for the currently selected configuration tab, use the "Set to Default Values"
menu item from the "Selected Tab" sub-menu in the File menu.
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Printing

To create a paper copy of your configuration, you can print the settings for the selected unit or the
currently selected configuration tab:

Menu Item Description \

File = Print... Prints the configuration settings for the selected unit.

File = Selected Tab = Print... Prints the configuration settings for the currently
selected tab.

File IﬁPrint Preview Opens a print preview window displaying the

configuration settings for the selected unit.
File = Selected Tab & Print Preview Opens a print preview window displaying the
configuration settings for the currently selected tab.
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Print preview window
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Firmware and Unit Numbers

Uploading Firmware

:‘,E Uploading firmware may erase your configuration. It is strongly
- recommended that you first save your configuration to an archive file.

SEE SAVE AND RESTORE SYSTEM CONFIGURATION (PAGE 24) FOR MORE
INFORMATION.

Note: For current firmware versions, visit www.burk.com.

#1/0 16, 1/0 8, VRC2500, and Voice Interface

Important Notes:

e You can only upload firmware using a null modem cable connected directly to the target
unit.

e ltis strongly recommended that you remove all other units from the G-Bus, if applicable.

e Forinformation on which serial port on your unit is used for firmware, see the Installation
and Operation Manual for your unit, available at www.burk.com.

To upload firmware, use the "Upload Firmware..." item from the Tools menu. If you are not already
connected, AutoLoad GSC will prompt you to connect.

When the firmware upload process is complete, verify your unit is running the desired version of
firmware (you can see the firmware version of the selected unit in the AutoLoad GSC status bar).

G-Link™ Units

Note: G-Link firmware is loaded via the G-Bus. Your G-Link unit must already be connected to at
least one I/O unit before uploading firmware, and AutoLoad GSC must already be connected to your
system.

To upload firmware, use the "Upload G-Link Firmware..." item from the Tools menu.

When the firmware upload process is complete, verify your unit is running the desired version of
firmware (you can see the firmware version of the selected unit in the AutoLoad GSC status bar).
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T Assigning Unit Numbers
The unit number uniquely identifies the unit on the G-Bus. Unit numbers range from o to 16 (16 is
reserved for the Voice Interface).

To re-assign a unit number, selected the desired unit and use the "Set Unit Number..." item from the
Tools menu. Choose an unused unit number and click OK to commit this change to the unit.

Set Unit Mumber Iﬁ
Unit number: :]

& (o

Set Unit Number dialog

Important Notes:

e You must always have one unit identified as unit o.

e Unit number 16 is reserved for the Voice Interface. The Voice Interface cannot use any
other unit number. You can only have one Voice Interface on the G-Bus.

e Some G-Link units require more than one unit number (GX-128 and OneConnect units).
When assigning unit numbers to one of these units, you are selecting the fist unit number.
The other unit numbers will always be sequential.
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3 Setting the System Password
The system password is a password stored on the locally connected unit (the unit to which you are
directly connected). The system password grants system-level (unrestricted) permission.

To set the system password, use the "Change Password..." item from the Tools menu. The password
may be up to eight characters long.

Important Notes:

e The default password is PASSWORD.

e Changing the system password is strongly recommended.

e Passwords are not case-sensitive.

e You may create additional passwords if desired. SEE USERS (PAGE 17) FOR MORE
INFORMATION.

e Adding additional user accounts does not override the system password.
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Options

To access the options dialog, use the "Options..." item from the Tools menu.

Gatians

L

General | futs Seve | Misers Optaors | Mascss Cobars

o] Shiow waloosa BEnsem

V| Save paasword aher cotnecing

Conmecion Setings
@ Aotomabically dedermine setings

Use spescific setings

General

Show welcome screen
When checked, AutoLoad GSC will show the welcome screen on
startup.

Save password after connecting
When checked, AutoLoad GSC will save your password so that you
won't need to enter it when you connect in the future.

Note: If you opt to save your password, AutoLoad GSC will encrypt it
using industry-standard encryption.

Connection Settings

By default, AutoLoad GSC will automatically determine the
appropriate response timeout and maximum retries based on
actual connection performance.

If desired, you may set these values manually by selecting the "Use
specific settings" option.

Response Timeout
This is the duration (in milliseconds) that AutoLoad GSC will wait
for a response from the site.

Maximum Retries
This is the number of times that AutoLoad GSC will retry a
command if the previous attempt timed out.
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AutolLoad GSC can automatically save a backup copy of your
configuration. To enable or disable this feature, use the
"Automatically save a copy of each site's configuration" checkbox.

When enabled, the Auto Save feature has several options that
control how often it creates a backup:

After every connection an upload

AutoLoad GSC will save a new backup file every time you connect
to a site or upload configuration. While this is the "safest" option, it
will create a large number of backup files.

Once per day at most

AutolLoad GSC will create a backup file when you connect or
upload, but will only create one file each day. If a file for today has
already been created, AutoLoad GSC will overwrite that file.

Once per week at most

AutoLoad GSC will create a backup file when you connect or
upload, but will only create one file each week. If a file for this week
has already been created, AutoLoad GSC will overwrite that file.

Once per month at most

AutolLoad GSC will create a backup file when you connect or
upload, but will only create one file each month. If a file for this
month has already been created, AutoLoad GSC will overwrite that
file.

Keep only one copy

AutoLoad GSC will keep only one backup file per unit. If a backup
file already exists, AutoLoad GSC will overwrite it. This option does
not facilitate restoring older configuration, but is the simplest to
use and require the least amount of disk space.

AutolLoad GSC will save backup files to the following location:

%Al1lUsersProfile%\Burk Technology\AutoLoad GSC\AutoSave
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Show syntax help
When checked, the macro editor will show help text for the
selected keyword at the bottom of the screen.

Show syntax suggestions
When checked, the macro editor will show a popup with possible
keyword matches for the term you are currently typing.

Automatically check for errors
When checked, the macro editor will check your code for errors as
you add/edit lines of code.

Show macro code in color

When checked, the macro editor will use different colors (see
below) to identify different elements of your macro code
(keywords, constants, etc).

Automatically capitalize macro keywords

When checked, the macro editor will capitalize the keywords in
your code. This makes it easier to create consistent, readable code,
but does not impact macro functionality.
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Note: Most of the color specifications below are only used when the
"Show macro code in color" option is enabled (see above).

Background
The background color of the macro editor. Use the "Window" color
to use the default color specified in Windows (recommended).

Macro Keywords
Sets the color used to identify keywords in your macros (if
enabled).

Variables
Sets the color used to identify variables in your macros (if enabled).

Constants
Sets the color used to identify constants in your macros (if
enabled).

Strings
Sets the color used to identify strings in your macros (if enabled).

Other Text

Sets the color used for all other text in your macro. If you have
disabled macro code coloring, all text will use this color. Use
"WindowText" to use the default color specified in Windows
(recommended).

Syntax Errors
Sets the color used for macro code that the editor cannot compile
due to syntax errors.

Error highlight
Sets the color used to highlight syntax errors.
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Appendix A — Setting an Action

The action popup allows you to define an action that the unit will take as a result of some other event
(determined by the context in which this popup is displayed).

Action: MNone -
Lnit:
Channel:

0K || Cancel

Action popup
Action
Select the type of action you want to take (Issue a command, run/stop a macro, or take a capture)
Unit

Select the unit where this command should be executed.

Channel/Macro

For applicable actions, select the channel or macro to which this command applies.
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