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Introduction 
 
AutoPilot® 2 gives you the power to monitor and control your entire operation from your PC. 
The user-friendly meter view and simplified navigation make AutoPilot easy to learn and use. 
With AutoPilot Scripts, you have the power and flexibility you need to for advanced 
automation. Whether you have one site or a hundred sites, AutoPilot 2 gives you the control 
you need. 
 
Minimum System Requirements 
 

• 400 MHz or higher processor 
• Windows® NT 4.0 w/ SP5, Windows 2000 Professional w/ SP1, Windows XP 
• 50MB free hard drive space 
• 128MB RAM 
• Microsoft Internet Explorer 4.01 w/ SP2 or higher 
• 640x480 screen resolution (800x600 recommended) 
• One available COM port for each direct cable connection 
• Bell 212A compatible modem for dial-up modem connection 
• CD-ROM Drive 
• Multimedia speakers (if using the audible alarm feature) 
• ARC-16 firmware version 5.0 or higher (5.4 recommended) 

 
Getting Started 
 
The included Quick Start Guide will help you setup and connect to your first site. This manual 
will provide you with instructions for: 
 

• AutoPilot Configuration 
• Basic Operation 
• Writing Scripts 
• Viewing Reports 

 
Getting Additional Help 
 
This manual contains all of the information provided in the program’s help file. To access this 
information from AutoPilot, click on the help menu and choose contents. You may also use 
the “What’s This” help function by clicking on the ? icon in the window’s title bar and then 
clicking on the item you need help for. 
 
If you need further assistance, please contact us at the number on the bottom of each page. 
You may also email us or visit the support section of our website. Our website and support 
email address are also listed on the bottom of each page. 
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ARC-16 Setup 
 
The ARC-16 Wizard takes you step-by-step through the process of adding ARC-16’s to 
AutoPilot. This section of the will guide you through each page of the wizard. To start the 
wizard, click "New ARC-16" from the File menu. 
 

 
 
To change your ARC-16 settings, you can return to the ARC-16 Wizard by clicking "ARC-16 
Properties..." from the Edit menu. To delete an ARC, click "Delete ARC-16..." from the Edit 
menu. Note: you can only add a new connection using the wizard when you first setup the 
ARC-16. To add connections later, see Managing Connections. 
 
ARC-16 Properties 
 

 
 
Site Name 
Enter a name for your ARC-16. This name will be used to select your ARC-16 in AutoPilot, 
as well as in scripts. 
 
Serial Number 
Enter your ARC-16's serial number. The serial number is printed on the back of the ARC-16, 
and appears at the end of the configuration menu on the front panel of the unit. 
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Password 
Enter the User Password for your ARC-16. This appears in the system configuration menu 
on the ARC-16. Re-enter the password in the "Confirm Password" field. 
 
Authorization Code 
Enter the authorization code that appears on the registration sheet sent with your order. If 
you need a replacement copy, please contact Burk Technology. Each ARC-16 requires its 
own authorization code 
 
ARC-16 Group 
 

 
 
ARC-16 Groups 
Every ARC-16, including a Stand Alone unit, must be part of a group. A group can include up 
to four units, all connected to each other. When AutoPilot connects to one ARC-16 in the 
group, it can talk to every other ARC-16 in that group as well. 
 
To add a new group, choose "Add new group..." from the list. If the ARC-16 you are adding 
will belong to a group you have already created, just select that group from the "Choose a 
Group" drop down list.  
 
Site Letter 
Select the site letter (site ID) for your ARC-16. The site letter of the ARC-16 is setup when 
you first configure your ARC-16. Note: each letter can only be used once for each group. If 
you have not changed the site ID for your ARC-16, you will find it on the factory configuration 
sheet that was sent with the ARC-16. 
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Time Zone 
 

 
 
When AutoPilot takes a log, or runs a script, it is sensitive to which time zone your ARC-16 is 
in. Choose the appropriate time zone from the list. You can also enter abbreviations for 
Standard Time and Daylight Time. These abbreviations will appear in your logs. If your time 
zone does not use Daylight Saving Time (DST), remember to uncheck the DST option. Note: 
if you are not using DST, AutoPilot will ignore the Daylight Time abbreviation field. 
 
Logging Options 
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Enable Logging 
Check "Enable Logging" if you want AutoPilot to log readings from this ARC-16. 
 
Interval 
Enter the number of hours or minutes after which AutoPilot should record a log. Select 
"Hours" or "Minutes" using the options below the interval field. 
 
Next Log 
Enter the time when AutoPilot should take its first log for this ARC-16. This will set a pattern 
for all future logging. For example, to log every hour on the hour, enter 1 for the interval and 
select "Hours", and enter the time for the next log to be taken. If the next hour is 6:00, 
AutoPilot will log at 6:00, 7:00, 8:00, etc. If you set the interval for 15 minutes, AutoPilot will 
log at 6:00, 6:15, 6:30, etc. 
 
Add New Connection 
 

 
 
Select "Yes" to add a new connection for this ARC-16. If you already have a connection for 
an ARC-16 in this group, you do not need to add another one. Select "No" to skip to the 
connection settings and “add channels” (see page 10). If you choose to add a new 
connection, you will be taken to the “connection details” page shown on the next page. 
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Connection Type 
Choose either a direct connection (using your computer's serial port and a null modem 
cable), or a modem connection (using your modem to dial into the ARC-16). 
 
Connection Name 
Enter a name for the connection. The connection name will identify this connection in 
AutoPilot and in scripts. 
 
Default Connection 
Check this box to make this the default connection for the group. When connecting to any 
ARC-16 in the group, AutoPilot will use this connection without asking you to first choose 
from a list. Note: when you select a default connection, you can still choose a different 
connection method by clicking "Connect Using..." from the File menu. 
 
Connect Automatically 
If you made this the default connection, you can check this option to allow AutoPilot to 
connect to this group when the program is started. 
 
COM Port (not shown) 
If using a direct connection, choose the COM Port that you want to use from the list. Note: if 
you do not see your COM Port in the list, it is not installed correctly in Windows. 
 
Modem 
If using a modem connection, choose the modem that you want to use from the list. Note: if 
you do not see your modem in the list, it is not installed correctly in Windows. 
 
Phone Number 
If using a modem connection, you must also enter the phone number that you want AutoPilot 
to dial. 
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Add Channels 
 

 
 
Add Channels 
Click the checkbox in the "Add" column for each ARC-16 channel you want AutoPilot to 
display. Note: adding a channel adds analog readings, control, and status. 
 
Channel Label 
Enter a label for your analog metering channel. Note: control and status labels will be 
entered later. As you type in the name, it will appear in the sample meter to the left allowing 
you to see if your label fits. 
 
Units 
Enter the units in which your analog readings are measured. 
 
Sample Meter 
The sample meter will show you what your channel will look like in AutoPilot. You can use 
this to make sure your labels will fit in the space allowed. Note: pressing the Raise and 
Lower buttons on the sample meter will move the needle from minimum to maximum. 
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Channel Properties 
 

 
 
Select a Channel 
Select the channel that you want to edit from the drop down list. 
 
Raise and Lower Labels 
You can change the labels for Raise and Lower. These labels will appear in AutoPilot, and 
will be used when logging commands. 
 
Raise and Lower Duration 
Enter the duration of the command. The duration can be from 0.5 to 28 seconds. 
 
Status On/Off Labels 
Enter labels for on and off status conditions. These labels will appear next to the status LED 
in AutoPilot, and in your logs. 
 
Status On/Off Colors 
You can also change the color of the status LED for on and off. Click on the color swatch to 
pick the color you want. 
 
Log Status Changes 
Check this box to have AutoPilot log each time the status of this channel changes. 
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Meter Properties 
 

 
 
Select a Channel 
Select the channel that you want to edit from the drop down list. 
 
Meter Colors 
Click on a color swatch to change the color. The meter colors are numbered top to bottom. 
You can use up to five colors, but to use fewer, set the "Ends at" value to be greater than or 
equal to the maximum value. For example, if you want your meter to range from 0 to 100 and 
use two colors, set the ends at value of colors 3-5 to equal the minimum value, and set color 
2 to any value between 0 and 100. 
 
"Ends at" 
The "Ends at" field determines the value at which the meter color ends. The range of values 
is -1,000 to 10,000. Meter Color 1 is always set to 10,000, since this is the highest value 
allowed. 
 
Minimum Value 
Enter the minimum value for the meter. If a reading is below the minimum value, the meter 
will point directly to the left, but still display the correct value. 
 
Maximum Value 
Enter the maximum value for the meter. If a reading is above the maximum value, the meter 
will point directly up, but still display the correct value. 
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Managing Connections 
 
You can add a new connection when you first setup your ARC-16 using the ARC-16 Wizard. 
To add a connection afterwards, or to modify an existing connection, click "Connections..." 
from the Edit menu. 
 

 
 
Adding a new connection 
Press "New" to add a connection. You must also select which ARC-16 you will be connecting 
to directly, using the "ARC-16" drop down list. Press save when you have finished setting up 
your connection. 
 
Modifying a connection 
Click on a connection in the "Choose a connection" list. When you have finished changing 
your settings, press save. If you want to revert to your original settings, press Undo. 
 
Deleting a connection 
To delete a connection, select it from the "Choose a connection" list, and click the Delete 
button on the Connections dialog. If you delete your only connection to a group, you will no 
longer be able to connect to that group. 
 
Connection Name 
Enter a name for the connection. The connection name will identify this connection in 
AutoPilot and scripts. 
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Default Connection for the group 
Check this box to make this the default connection for the group. When connecting to any 
ARC-16 in the group, AutoPilot will use this connection without asking you to first choose 
from a list. Note: you can still choose which connection to use by clicking "Connect Using..." 
from the File menu. 
 
Connect automatically on startup 
If you made this the default connection, you can check this option to allow AutoPilot to 
connect to this group when the program is started. 
 
Connection Type 
Choose either a direct connection (using your computer's serial port and a null modem 
cable), or a modem connection, using your modem to dial into the ARC-16. 
 
COM Port 
If using a direct connection, choose the COM Port that you want to use from the list. Note: if 
you do not see your COM Port in the list, it is not installed correctly in Windows. 
 
Modem (not shown) 
If using a modem connection, choose the modem that you want to use from the list. Note: if 
you do not see your modem in the list, it is not installed correctly in Windows. 
 
Phone Number (not shown) 
If using a modem connection, you must also enter the phone number that you want AutoPilot 
to dial. 
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Managing Groups 
 
An ARC-16 "group" can comprise up to four units. Every ARC-16 in AutoPilot is part of a 
group, even if you are only using one ARC-16. When you connect to any ARC-16 in a group, 
AutoPilot is able to communicate with all of the units in that group. 
 
To add, delete, or edit groups, click "Groups..." from the Edit menu. 
 

 
 
Adding Groups 
Click New to create a new group. Enter a name for the group, and press save. Because this 
is a new group, there will not be any other ARC-16s in this group and there will not be any 
connections to it. 
 
Modifying Groups 
Select the group from the Groups list. You can change the name, and set one of the 
connections to the group as the default. If you make a mistake, you can click Undo to revert 
to the original settings. 
 
Deleting Groups 
Select the group that you want to delete from the Groups list. Click the Delete button on the 
dialog to delete it. Warning: when you delete a group, all of the ARC-16s and connections for 
that group will be deleted as well. 
 



AutoPilot® 2 Instruction Manual  16 

 
 

TECHNICAL SUPPORT: 978-486-0086 • support@burk.com • www.burk.com 
 

Groups list 
The Groups list displays all of the groups that you have added to AutoPilot. Clicking on a 
group in the list will display its properties in the fields below. 
 
Group Name 
The group name is used to refer to this group in AutoPilot. 
 
ARC-16s in this Group 
The ARC-16 list shows all of the ARCs, if any, that are part of this group. 
 
Connections to this group 
The connections drop down list displays all of the connections to this group (connections can 
be defined to any of the ARC-16s in the group). Select a connection if you want to change its 
default status. 
 
Default Connection 
If a connection is the default for the group, AutoPilot will use that connection when 
connecting without first prompting you to choose from a list. 
 
Connect to this group automatically at startup 
If the connection is the default for the group, AutoPilot can use it to connect when the 
program starts up. 
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Managing Users 
 
AutoPilot user accounts are used to restrict access to AutoPilot and some of its features to 
only the people whom you choose. An Administrator account is built in. This account cannot 
be deleted, but can be renamed. Note that the default password is blank; to change this 
password, see below. 
 
To access the Edit Users dialog, click "Users..." from the Edit menu. 
 

 
 
Add a new user 
Press New to create a new user. You can change the User Name and set a password, as 
well as assign privileges (see below). Press Save to save your changes. 
 
Modify a user 
Select the user that you want to edit from the Users list. You can change the name, 
password, and privileges (see below). Press Save to save your changes, or press Undo to 
revert to the original settings. 
 
Delete a user 
To delete a user, press the Delete button on the Edit Users dialog. Note: you cannot delete 
the built-in Administrator account. 
 
Users list 
To edit or delete a user, click on the desired user name from the Users list. 
 
User Name 
The user name can be up to 25 characters long. 
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Password 
The password can be up to 16 characters long, but can be left blank if desired. You must 
retype the password in the Confirm Password field. 
 
Privileges 
 
Privilege Description 
Administrator Grants the user all other privileges, as well as the ability to manage other users.
Manage ARC-16s Allows the user to add, delete, and edit ARC-16s, connections, and groups.
Connect/Disconnect The user can connect and disconnect ARC-16s.
Issue Commands Gives the user the ability to issue raise and lower commands. 
Clear Alarms Allows access to the Clear Alarms button.
Enable/Disable Scripts The user will be able to enable and disable scripting.
Run/Schedule Scripts Allows the user to run scripts, or change the schedule settings of a script.
Write Scripts Gives the user access to the Script Editor and Script Wizard. 
Enable/Disable Logging The user can enable and disable logging in AutoPilot.
View Logs and Reports Allows access to the Report writer and export features.
Edit Calendars Grants the user access to the Edit Calendars dialog.
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Basic Operation 
 
Logging In 
 

 
 
When AutoPilot starts, you will be prompted to log in. Select your user name from the drop 
down list, and enter your password in the Password field. Click Login to continue. If you 
entered your password incorrectly, you will be prompted to log in again. Click Cancel to close 
AutoPilot. Note: you cannot run AutoPilot without logging in. 
 
Auto Login 
Check the "Always log in as this user automatically" box to enable Auto Login. When 
AutoPilot starts, it will automatically log in using the user name and password that you 
entered. Note: this feature can be turned off from the Options dialog. 
 
Logging Off 
You can log off of AutoPilot by clicking on "Log off..." in the File menu. After logging off, you 
will be prompted to log in as a different user with the Login dialog. 
 
Connecting to your ARC-16 
 
When AutoPilot connects to an ARC-16, it will also talk to all of the other units in the group - 
allowing you to control up to four ARCs with one connection. You must add a connection to 
at least one ARC-16 in the group before you can connect. You can add connections in the 
ARC-16 Wizard, or from the Edit menu. 
 

 
 
Establish a Connection 
Click on the tab for the ARC-16 that you want to connect to, or any other ARC-16 in the 
same group. To connect, click "Connect" from the toolbar or File menu. If you have a 
"default" connection, AutoPilot will use that connection. Otherwise, you will be prompted to 
choose from a list of connections for the group. If you want to override the default, click 
"Connect Using..." to see the list of connections. 
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Connection Details 
 
To view the Connection Details dialog, click "Connection Details" from the View menu. 
 

 
 
Connected since 
The connected since field shows the date and time that the connection was established. 
 
Connected via 
Connected via shows the COM Port or modem that AutoPilot is using for the connection. 
 
Quality 
The quality field indicates how stable or "clean" the connection is. The field shows a 
percentage - 100% indicating a flawless connection. This value is actually the percentage of 
readable or "good" packets received from the ARC-16. If some packets are unreadable, you 
will see a value of less than 100%. If you see a low value, for example 75%, this means that 
AutoPilot is unable to read 25% of the data being reported by the ARC-16. This also means 
that if you issue a command, there is a 25% chance that the ARC-16 will not receive it. Poor 
connection quality may be the result of a bad null modem cable or a noisy phone line. 
 
Connected to 
This shows which ARC-16 you are connected to directly. 
 
Other ARC-16s using this connection 
This list includes the other ARC-16s in the group that are connected through the unit in the 
"connected to" field. 
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Commands 
 

 
 
To issue a raise or lower command, just click on the command button (as seen above). The 
command will be issued using the duration that you set in the ARC-16 Wizard. Note: both of 
the command buttons for this channel will be "locked out" for the duration of the command. 
You can still issue commands to other channels, though. When a command is issued, it is 
logged in the Event Log. 
 
If the command is locked out... Commands will be "locked out" (command buttons will 
appear grayed out) under the following circumstances: 
 

• You are not connected to the ARC-16.  
• You just issued a command to this channel and the duration has not yet elapsed.  
• Your ARC-16 is in Maintenance Mode.  
• You do not have permission to issue commands.  

 
Navigation and ARC-16 Status 
 
Navigating between ARC-16s 
To switch from one ARC-16 to another, click on the tab for that site. 
 

 
 
ARC-16 Status Indicators 
Each ARC-16 is shown with a status indicator. This will indicate the connection, alarm, and 
maintenance mode status. 
 

 A gray icon indicates that you are not connected. 
 A green icon indicates your connected, the red dot indicates active alarms. 
 A yellow icon indicates the unit is in maintenance mode, the red dot indicates alarms. 
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Menus, Toolbar, and Status bar 
 
Menus 

File Menu Description 
New ARC-16 Opens the ARC-16 Wizard to add a new ARC-16. 
Connect Connects using the default connection for the group. If no default is defined, the 

connection list will be displayed. 
Connect Using Displays the connection list. 
Print Report Opens the Report Writer. 
Export Data Opens the export dialog. 
Clear Alarms Clears all alarms on the currently selected ARC-16. 
Log Off Logs off the current user and displays the Login dialog. 
Exit Closes AutoPilot. 

 
Edit Menu Description 
ARC-16 Properties Opens the ARC-16 Wizard to edit the settings for the currently selected ARC-16. 
Connections Opens the Edit Connections dialog. 
Groups Opens the Edit Groups dialog. 
Delete ARC-16 Deletes the currently selected ARC-16. 
Calendars Opens the Calendars dialog. 
Users Opens the Edit Users dialog. 
Change Password Allows the user who is logged in to change his or her AutoPilot password. 
ARC-16 Display Order Opens the ARC-16 Display Order dialog. 

 
View Menu Description 
Events Displays the Event List. 
Alarm History Displays the Alarm History List. 
Active Alarms Opens the Active Alarms dialog. 
Connection Details Opens the Connection Details dialog. 

 
Tools Menu Description 
Enable Logging Enables/disables logging. 
Scripts: Enable Scripts Enables/disables scripts. 
Scripts: Script Editor Opens the Script Editor. 
Scripts: Script Wizard Opens the Script Wizard. 
Scripts: Scheduler Displays the Script Scheduler. 
Options Displays the Options dialog. 

 
Help Menu Description 
Contents Opens the help file and displays the Table of Contents. 
Index Opens the help file and displays the Index. 
Search Opens the help file and displays the Search page. 
About AutoPilot Shows the About dialog for AutoPilot. 
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Toolbar 
Toolbar Item Description 

Log Off Logs off the current user and displays the login dialog. 

 
Connect Connects using the default connection for the group. If no default is defined, the 

connection list will be displayed.

 Clear Alarms Clears all alarms on the currently selected ARC-16. 

 New ARC-16 Opens the ARC-16 Wizard to add a new ARC-16. 

 ARC-16 Properties Opens the ARC-16 Wizard to edit the settings for the currently selected ARC-16. 

 Enable Logging Enables/disables logging. 

 Report Writer Opens the Report Writer. 

 Event List Displays the Event List. 

 Alarm History Displays the Alarm History List. 

 Enable Scripts Enables/disables scripts. 

 Script Editor Opens the Script Editor. 

 Script Wizard Opens the Script Wizard. 

 Script Scheduler Displays the Script Scheduler. 

 Edit Calendars Opens the Calendars dialog. 

 Help Opens the help file and displays the Table of Contents. 

 
Status Bar 
 

 
 

Item Description 
Alarm LED This LED will be bright red if there is at least one active alarm. The LED will be 

dim if there are no alarms. 
Alarm Description The description will explain what type of alarm most recently occurred, and on 

what ARC-16 and channel. "No Alarms" will be displayed if there are no active 
alarms. 

Status This field will display the status of a time consuming operation (such as 
"Connecting..."). It will display "Ready" when there is no activity. 

Maintenance Mode "Maint Mode" will appear if the current ARC-16 is in maintenance mode, otherwise 
it will appear dimmed. 

Current User Shows which user is presently logged in. 
Time Shows the current time. 
Date Shows today's date. 
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Logging 
 
AutoPilot will log each ARC-16 for which you enabled logging during configuration. AutoPilot 
will also log status changes (for channels on which this feature is enabled), alarms, and 
events. 
 
To enable logging, click "Enable Logging" from the Tools menu in AutoPilot. Note: the 
logging icon will appear down by the clock in the Windows taskbar “tray” (shown below). 
 

 
 

 Logging icon 
 
When logging is disabled, the logging icon will appear with a red line through it. Note: you 
can enable/disable logging by right clicking on this icon in the Tray. 
 
AutoPilot will continue to log after you close the program (the logging icon will remain in the 
Tray). This allows you to log without leaving AutoPilot open all the time. If you want to stop 
logging and close the logging application, right-click on the logging icon in the Tray, and click 
on "Exit". 
 
Note: if you are connected to any of your ARC-16s when you close AutoPilot, the logging 
application maintains those connections. If you are using a modem and want to free up the 
phone line, be sure to disconnect before closing AutoPilot. 
 
Connecting to ARC-16s for Logging 
If AutoPilot needs to log an ARC-16 that is not connected, it will connect to the ARC-16 first, 
and disconnect when it is finished. Note: you must define a default connection for this feature 
to work. 
 
If AutoPilot needs to use a modem that is already in use, it will prompt you to either 
disconnect the modem first, or cancel the log. If you are not at your computer when this 
prompt appears, AutoPilot will automatically disconnect the modem, dial the ARC-16 that it 
needs to log, and then re-connect the modem.  
 
Note: AutoPilot can only disconnect/reconnect the modem if it is in use by AutoPilot, not by 
any other application (for example, if you are using your modem to connect to the Internet). 
 
Using One Modem for Multiple ARC-16s 
AutoPilot can use one modem to log multiple ARC-16s that are not in the same group. To do 
this, define a modem connection to at least one ARC-16 in each group that you want to log. 
When AutoPilot needs to log one of these ARC-16s, it will use the modem to establish a 
connection, log each ARC-16 in the group, and then disconnect - freeing up the modem to 
log another ARC-16. 
 
Note: when setting up your logging interval, be sure to take into account the time required for 
the modem to establish a connection. If your intervals are too short, AutoPilot may not be 
able to log all of your sites quickly enough. 
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Logging Status 
To view logging status, double-click on the logging icon in the taskbar “tray”. 
 
The Logging Status window (shown below) shows if logging is enable/disabled in its status 
bar, as well as all of the logging events. 
 

 
 
Alarms 
 
Options for handling alarms can be set using the Options dialog. 
 
Alarm Indicator Icons 

 Status Alarm 
 Low Limit Alarm 
 High Limit Alarm 

 
Alarm History 
The Alarm History window (shown below) shows all the alarms logged by AutoPilot.  
 

 
 
Active Alarms 
The Active Alarms window (shown on next page) shows all the alarms that are currently 
active. An alarm is active if the channel is still out of tolerance (above upper limit, below 
lower limit, or if the status is on). 
 
Check "Hide this list when there are no more alarms" if you want AutoPilot to close this dialog 
when there are no longer any active alarms. 
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Clearing Alarms 
To clear alarms on the ARC-16, click "Clear Alarms" from the File menu. Note: this will only 
clear alarms on the ARC-16 (the Clear light on the front panel of the unit will turn off). Alarms 
will still appear as "active" in AutoPilot until the channel is no longer out of tolerance. 
 
Events 
 
To view the event list (shown below), click "Events..." from the View menu. To change 
settings for the events list, use the Options dialog. 
 

 
 
Events are categorized using eight Event Types: 
 

Event Type Description 
Application Application events include logging on/off, and opening/closing the program. 
Connection Connection events report connecting, disconnecting, and answering calls. 
Commands Command events report Raise and Lower commands.
Alarms Alarm events indicate that Clear Alarms was pressed.
Logging Logging events indicate when logs are taken, and include failed logging connections.

Scripts:  Script events include enabling and disabling scripts, as well as error messages produced 
by scripts. 

Maint Mode Maint Mode events indicate that an ARC-16 went in to, or out of Maint Mode. 
Script Message Messages printed from scripts.
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Calendars 
 
Calendars are used in scripts, usually to run operations specific to a certain time of day (such 
as sunrise or sunset). You can add as many calendars to AutoPilot as you desire. For each 
calendar, you can specify a time zone. All times are entered in Standard Time. AutoPilot will 
account for Daylight Saving Time when using calendar values (if the time entered is 5:00 AM 
for Pre-Sunrise, AutoPilot will interpret Pre-Sunrise as 6:00 AM during DST). 
 
To add or edit a calendar, click "Calendars..." from the Edit menu. 
 
Adding a new Calendar 
 

 
 

1. Click the "New" button to create a new calendar.  
2. Enter a name for the calendar in the Name field. This name will be used in scripts.  
3. If the calendar is not set for your local time zone, press the "..." button to open the 

time zone window. Here you will be able to choose your local time zone. 
4. Enter times (12 hour) for each field, using Standard Time.  
5. Press Save to save your changes.  

 
Note: you must enter calendar times in Standard Time regardless of whether you are in 
standard or daylight savings. 
 
Modifying a Calendar 
To modify a calendar, select the calendar from the drop down list (the Name field). You can 
change the name, time zone, and the time fields. 
 
Deleting a Calendar 
To delete a calendar, select it from the list and click the "Delete" button. 
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Changing your Password 
 
To change your AutoPilot password, click "Change Password" in the Edit menu. 
 

 
 
Enter your old password in the "Old Password" field. Enter a new password in the "New 
Password" and "Confirm New Password" fields. The password can be up to 16 characters 
long, and can be left blank if desired. 
 
Note: this changes only your AutoPilot user password. You cannot change the password on 
your ARC-16 through AutoPilot. 
 
ARC-16 Display Order 
 
To change the order in which ARC-16s are displayed in AutoPilot, click "ARC-16 Display 
Order..." in the Edit menu. 
 

 
 
Select the ARC-16 that you want to move. Click Move Up or Move Down to rearrange the 
ARCs. Press OK or Apply to save your changes.  
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General Options 
 
To access the options menu, click on the “Tools” menu and then choose “Options.” 
 

 
 
Show Meter Numbers 
Click Show Meter Numbers to display the number of each meter, as seen below: 
 

 
 
Hide Inactive Channels 
If this box is checked, unused channels will be hidden rather than shown as disabled. 

Stop Scripts/Logging on Exit 
Check this box to close the Script/Logging components when AutoPilot is closed. If this box 
is left unchecked, Scripting/Logging will continue to run even when AutoPilot is shut down. 

Time Format 
Choose either 12 or 24-hour time. AutoPilot will use this setting when you are prompted to 
enter times (such as in the Calendar). 
 
Grid Navigation 
The Grid Navigation setting controls the behavior of the TAB key when using a grid in 
AutoPilot. The first option, "Tab moves to next control", will use the TAB key to move from 
the grid to the next field, button, or other control on the dialog/window. This option facilitates 
using the keyboard to enter data without needing the mouse to move to another field. The 
other option, "Tab moves to the next field in grid", uses the TAB key to move from field to 
field within the grid. When the last cell in the grid is reached, the TAB key will not move the 
cursor anywhere. Note: the arrow keys can always be used to move from cell to cell in a grid. 
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Alarm Options 
 
To access the options menu, click on the “Tools” menu and then choose “Options.” 
 

 
 
Show Alarm History 
Check this box to show the Alarm History list when a new alarm is found. 
 
Show Active Alarms 
Check this box to show the Active Alarms list when a new alarm is found. 
 
Play a sound 
Check this box to play a sound when a new alarm is found (see below to choose a sound). 
 
Alarm Description Display 
Alarm descriptions in the Alarm History and Active Alarm windows can be shown as either 
text or icons. Text descriptions appear as Upper Limit, Lower Limit, and Status. Icon 
descriptions appear as red or yellow arrows, or a red light for status. 
 
Sound File 
Click the "..." button to browse for a sound file on your computer. Press play to hear the 
sound. 
 
Always On Top 
Check this box to always show the Alarm History window on top of other windows. This 
setting can also be changed by right clicking on the Alarm History. 
 
Number of alarms to show in Alarm History 
Move the slider to set the number of alarms shown in the Alarm History list. The range is 10 
to 1000. 
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Event List Options 
 
To access the options menu, click on the “Tools” menu and then choose “Options.” 
 

 
 
Types of events to show in the list 
Click the check box for each type of event that you want included in the Event List. When you 
click on a category, its description will appear to the right of the list. 
 
Number of events to show in the Event List 
Move the slider to set the maximum number of events shown in the Event List. The range is 
10 to 1000. 
 
Incoming Calls 
 
To access the options menu, click on the “Tools” menu and then choose “Options.” 
 

 
 
AutoPilot can answer incoming calls from an ARC-16 using your modem(s). To allow a 
modem to answering incoming calls, click the check box next to the modem name. 
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Optionally, AutoPilot can automatically disconnect incoming calls after a specific duration. To 
enable this feature, check the “Disconnect incoming calls after…” box and enter the desired 
number of minutes in the adjacent field. 
 
Auto Login 
 
Auto Login allows AutoPilot to log in as a specific user when the program stats, without 
prompting for a password. 
 

 
 
Enable Auto Login 
Check this box to enable the Auto Login feature. 
 
User 
Select the user that you want AutoPilot to use when logging in. 
 
Password 
Enter the password for the user you selected. 
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Purge Data 
 

 
 
Purge Settings 
Click on the check box for each type of data that you want to purge. Enter the number of 
days after which AutoPilot should purge the data. If you enter 30 days for Telemetry, for 
example, you will never have any Telemetry records older than 30 days. 
 
Note: purging data may improve application performance. If the Report Writer is slow to 
generate reports, or the Event List takes a long time to open, specify a more frequent purge 
interval to reduce the number of records stored in the database. If you wish to save the data 
for future use, be sure to export it before purging (see Exporting Data). 
 
AutoPilot will purge old data when the application starts up. If you run AutoPilot continuously, 
use the Purge Now function to purge data without restarting AutoPilot. 
 
Purge Now 
Click the Purge Now button to run the purge immediately. 
 
Compacting the Database 
Your database files must be compacted periodically to save disk space. AutoPilot will 
compact at startup, but this can take several seconds (depending on the size of your 
database files). Set the number of days after which AutoPilot should compact.  
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Scripting Options 
 

 
 
Continuous Script Interval 
Select the desired interval for continuous scripts (looping). This is the number of seconds 
that AutoPilot will wait after running the script before running it again. For example, if you 
want continuous scripts to run every 10 seconds, set the interval to 10. 
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Scripts 
 
AutoPilot Scripts allow you to fully automate your sites using the power of Visual BASIC 
Script.  
 
Scripts will run when only when Scripting is enabled. To enable scripting, click "Enable 
Scripts" from the Tools/Scripts menu. Note: the scripting icon will appear down by the clock 
in the Windows taskbar “tray” (shown below). 
 

 
 

 Script icon 
 
When scripting is disabled, the script icon will appear with a red line through it. Note: you can 
enable/disable scripting by right clicking on this icon in the Tray. 
 
When you close AutoPilot, scripts will continue to run (the Script icon will remain in the Tray). 
This allows you to run scripts without leaving AutoPilot open all the time. If you want to stop 
scripts and close the scripting application, right-click on the script icon in the Tray, and click 
on "Exit". 
 
Note: you can double-click on the script icon in the taskbar ”task” to open Script Scheduler. 
 
Converting AutoPilot 1.x Functions 
 
If you have used a 1.x version of AutoPilot, you are probably familiar with AutoPilot 
Functions. With AutoPilot 2, Functions are no longer used. Instead, AutoPilot uses a scripting 
language based on Visual BASIC Script (VBS). To make the transition from Functions to 
Scripts easier, the following table explains the Script equivalent to the old Functions. 
 
 

Function Script Equivalent 
If Function Use the GetScriptStatus command in an If statement.  

 
If ScriptStatus(“Script”) = x Then 
... 
End If 

If Date Use the VBS Date() function in an If statement.  
 
If Date() = x Then 
... 
End If 
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If Time Use the VBS Time() function in an If statement.  

 
If Time() = x Then 
... 
End If 

If Day Use the VBS DatePart() Function in an If statement.  
 
If DatePart("w", Now()) = x Then 
... 
End If 

If Value Use the Value command in an If statement.  
 
If Value(“Site”, Channel) = x Then 
... 
End If 

If New Value Use the NewValue command in an If statement.  
 
If NewValue(“Site”, Channel) = x Then 
... 
End If 

If Status Use the Status command in an If statement.  
 
If Status(“Site”, Channel) = x Then 
... 
End If 

If New Status Use the NewStatus command in an If statement.  
 
If NewStatus(“Site”, Channel) = x Then 
... 
End If 

If Memory Use a variable in an If statement.  
 
Dim MyVar 
If MyVar = x Then 
... 
End If 

Set Function To run a script, use RunScript. 
To stop a script, use StopScript. 

Set Memory Use a variable.  
 
Dim MyVar 
MyVar = x 

Increment Use a variable.  
 
Dim MyVar 
MyVar = MyVar + 1 

Decrement Use a variable.  
 
Dim MyVar 
MyVar = MyVar - 1 

Raise Use the Raise command. 
Lower Use the Lower command. 
Wait Use the Wait command. 
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Goto Step Use a sub routine.  

 
Call MySub 
 
Sub MySub() 
... 
End Sub 

Message Use the Message command. 
Print Value Use the Message command.  

 
Message Value(“Site”, Channel) 

Print Status Use the Message command.  
 
Message Status(“Site”, Channel) 

Print Logline Use the TakeLog command. 
Connect Use the Connect command. 
Disconnect Use the Disconnect command. 
End Use the EndScript command.  

 
Note: you do not always need to use EndScript; a script will end after executing its last line 
of code. 
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Script Wizard 
 
The Script Wizard can help you generate scripts for some common tasks: 
 

• Transmitter Power Trim  
• Transmitter Restart  
• Transmitter Powerup  
• Pattern/Power Change  
• Antenna Monitoring  
• Tower Light  
• Main to Aux  
• Site Power Loss Recovery  

 
To launch the wizard, click "Script Wizard..." from the Tools/Scripts menu. 
 

 
 
Select the template that you want to use, and enter a name for the script. Press Next, 
and follow the instructions on each page to tailor the script to your needs. When the 
wizard is complete, you will have the option to open the script in the Editor, if you 
want to make any changes. For help editing the script, see Modifying a Wizard-
Generated Script. 
 
Note: when you save a script from the Wizard, it will begin to run right away if scripts 
are enabled. If you want to edit the script before it runs, save it to another folder on 
your computer, or disable scripts before saving. 
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Modifying Wizard Generated Scripts 
 
To modify a script that was generated by the Script Wizard, open the script in the Script 
Editor. The wizard-generated script looks just like any other script, but includes a list of 
Constants at the top. 
 

 
 
These constants reflect the settings you entered in the Wizard. You can edit the constant 
values if you want to change which ARC-16 or Channel the script uses. You can also add 
any additional code to the script, or remove code added by the Wizard. 
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Using the Script Editor 
 
To open the script editor, click "Script Editor..." from the Tools/Scripts menu. 
 

 
 
Using the Code Builder 
The Code Builder Toolbar will help generate script code using AutoPilot Script Commands 
(so you don't have to memorize the syntax for every command). 
 
Start by picking the command from the "Command" drop down list. The other fields on the 
toolbar will change depending on which command you selected. Fill in the fields, and press 
the "OK" button on the toolbar to add the code. 
 
Script Schedule Properties 
Click "Properties" from the File menu to change the schedule properties of the script. See 
Scheduling Scripts for more information. 
 
Saving your Script 
Click "Save" or "Save As..." from the File menu to save your script. 
 
Note: unless your script is scheduled to Idle, it will begin to run right away (as long as scripts 
are enabled). If you do not want the script to run yet, save it to another folder on your 
computer or disable scripts in AutoPilot. 
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Scheduling Scripts 
 

 
 
Scripts can be scheduled to run in five different modes. To set the schedule, open the Script 
Properties dialog from the Script Scheduler or Script Editor. Choose the type of schedule 
from the options shown above. 
 
On Demand Only (Idle) 
The script will only run if started from the Script Scheduler or if RunScript is used to start it 
from another script. 
 
Continuous 
The script will run in a loop. After the script runs, there is a break (about five seconds), and 
then it will run again. The script will continue running until the schedule is changed. 
 
Interval 
The script will run after a certain interval has elapsed. To set the interval, choose either 
Minutes or Hours, and enter the interval in the field. 
 
Specific Time 
 

 
 
The script will only run at the time selected (accurate to the minute). The script can be set to 
run at a specific time, or a calendar time. If using a calendar time, you must select the 
calendar that you want to use, as well as the time (Sunrise, Sunset, etc). 
 
The script can run every day, or only on certain days. Check the days of the week on which 
you want the script to run. 
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Between Times 
 

 
 
The script will run only between the times selected. For both the start and stop times, either a 
specific time or a calendar time can be used. If using a calendar time, you must select the 
calendar that you want to use, as well as the time (Sunrise, Sunset, etc). 
 
Note: if you want a script to start running before midnight, and stop running after midnight, 
AutoPilot will add one day to the stop time. For example, to run between 10:00 PM and 2:00 
AM, just enter those times exactly as they are. AutoPilot will run the script if it is later than 
10:00 PM today or earlier than 2:00 AM tomorrow. 
 
Using the Script Scheduler 
 
To open the Script Scheduler, click "Scheduler..." from the Tools/Scripts menu. 
 

 
 



AutoPilot® 2 Instruction Manual  43 

 
 

TECHNICAL SUPPORT: 978-486-0086 • support@burk.com • www.burk.com 
 

Script Status Icons 
Status Description 

Off (Idle) The script is not running. 

Running The script is running. 

Loop Wait The script is waiting to loop. 

Paused The script is paused (using Wait). 

Waiting to run between certain times The script is scheduled to run between two times. 

Waiting for Interval The script is scheduled to run after a certain interval. 

Scheduled The script is scheduled to run at a certain time. 

 Data Wait The script is waiting for data from an ARC-16 (using 
NewValue or NewStatus).

Connecting The script is connecting to an ARC-16 (using Connect). 

 
Running Scripts 
Select the script you want to run and click "Run" from the Scripts menu. 
 
Stopping Scripts 
Select the script you want to stop and click "Stop" from the Scripts menu. Note: this will not 
change the schedule of the script; it will just stop the script. 
 
Stop Looping 
Select a script that is in Loop Wait and click "Stop Looping" from the Scripts menu. Note: this 
will not stop the script, but only prevent it from running again by changing its schedule to Idle. 
This allows you to stop a loop while still allowing the script to complete its current run. 
 
Scheduling Scripts 
To change the schedule of a script, click "Schedule" from the Scripts menu. See Scheduling 
Scripts (page 41) for more information. 
 
Editing Scripts 
Select the script that you want to edit and click "Edit" from the Scripts menu to open the 
Script Editor. To delete the script, click "Delete" from the File menu. 
 
Adding New Scripts 
You can add a script using the Editor or the Wizard from the File/New menu. 
 
Script Errors 
 
If an error occurs in your script, it will be logged in the Event Log. Your script will stop 
immediately after the error. Errors may be caused by VBS syntax errors, or by referencing 
invalid ARCs, channels, connections, etc. 
 
Note: the Event Log will include the line number in your script that caused the error. 
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Error Descriptions 
Error Cause 
Internal Error This is not actually a script error, but an error occurred in AutoPilot 

while running your script. 
ARC-16 not found Your script referred to an ARC-16 that does not exist in AutoPilot. 
Connection not found You used the Connect command and specified a connection that  

does not exist. 
Default connection not found You used the Connect command without specifying a connection,  

but there is no default connection defined for the group. 
Timeout A Connect, NewStatus, or NewValue command failed because it 

received no response from the ARC-16. 
Invalid channel You specified a channel that is outside of the allowed range (1-16). 
Calendar not found A calendar command (Sunrise, Sunset, etc.) referred to a calendar 

name that does not exist in AutoPilot. 
Script not found A script command (RunScript, StopScript, etc.) referred to a script 

that does not exist 
 
Note: a "not found" error may be caused by a spelling mistake. 
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Writing Scripts 
 
If you're not familiar with Visual BASIC Script, the following sections will help you get started. 
The Script Command reference (page 50) is especially useful, even if you already know 
VBS.  
 
If Statements 
 
Use the VBS If statement in a script to make a decision. The If statement follows this basic 
structure: 
 
If [condition] Then 
[action] 
End If 
 
If...Then 
Here is an example of a simple If statement that prints a message if an analog channel is 
over 1000. 
 
Example 
 
If Value("MyARC", 1) > 1000 Then 

Message "Channel 1 is above 1000" 
End If 
 
Using Else 
You can add an Else clause to give the If statement an alternative. This example prints ON if 
the status is on, but prints OFF otherwise. 
 
Example 
 
If Status("MyARC", 1) = True Then 

Message "Channel 1 is ON" 
Else 

Message "Channel 1 is Off" 
End If 
 
 
Using ElseIf 
Use ElseIf to write more complex statements. If the first condition fails, the second condition 
will be tested. You can still use Else to provide an alternative if your If and ElseIf conditions 
fail. Note: you can use as many ElseIf statements as you like. 
 
This example tests an analog channel for a reading over 1000. If the reading is less than 
1000, it tests for a reading of less than 0. If both of these conditions are false, the Else action 
will be used. 
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Example 
 
If Value("MyARC", 1) > 1000 Then 

Message "Channel 1 is above 1000" 
ElseIf Value("MyARC" 1) < 0 Then 

Message "Channel 1 is below 0" 
Else 

Message "Channel 1 is between 0 and 1000" 
End If 
 
Variables and Constants 
 
You can use a variable to store data temporarily in a script. A variable can be changed while 
the script is running. A constant is like a variable, only it must be assigned a value when it is 
declared. Constants cannot be changed, however. 
 
Declaring a Variable 
To declare a variable, use the Dim keyword, followed by the variable name. Note: variable 
names can be up to 255 characters long, and must be unique (you can not use the same 
variable name twice in one script). 
 
To assign a value to a variable, just use the variable name followed by "=". Note: if the 
variable is going to hold text, you must use "quotes". 
 
Example 
 
'Create a variable named MyVar, and set it to equal 0 
Dim MyVar 
MyVar = 0 
 
'Add 1 to the variable 
MyVar = MyVar + 1 
 
'Assign the text "hello" to the variable 
MyVar = "hello" 
 
Declaring a Constant 
To declare a constant, use the Const keyword followed by the constant name, and assign it a 
value in the same step. Note: constant names follow the same rules as variable names (see 
above). 
 
Example 
 
'Create a constant named MyConst and set it to 100 
Const MyConst = 100 
 
Note: it is a good idea to use constants in your scripts when dealing with unchanging values, 
such as ARC-16 names. 
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Example 
 
'Use a constant to represent an ARC-16 named "WXZY FM Backup" 
Const MyARC = "WXYZ FM Backup" 
 
'Raise channel 1 on this ARC 
Raise MyARC, 1 
 
Functions and Subs 
 
Functions and Subs are used to encapsulate code in your script that you can run from 
elsewhere inside the script. This is useful if you want to perform the same action in different 
places in your script. 
 
Subs 
To declare a sub, use the Sub keyword followed by a unique name for the sub. Your sub 
must end with "End Sub." Here is the format of a sub: 
 
Sub SubName(Parameter1, Parameter2, ...) 
[action] 
End Sub 
 
You can use as many parameters as you want, or none at all. To run a sub, use Call followed 
by the name of the sub. 
 
Example 
 
Sub MySub(MyParameter) 

Message MyParameter 
End Sub 
 
'This will write a message with the text "hello" 
Call MySub("hello") 
 
Functions 
A function is just like a sub, only it "returns" a result. To assign the return value, include a 
statement like this: 
 
FunctionName = Value 
Example 
 
Function MyFunction(MyParameter) 

MyFunction = MyParameter + 1 
End Function 
 
'This will write a message with the text "2" 
Message MyFunction(1) 
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Loops 
 
You can use loops to repeat a section of code. For a complete reference on loops, visit 
Microsoft’s online scripting resource at http://www.microsoft.com/scripting. This section will 
cover "Do Loops". The basic structure of a Do Loop is:  
 
Do 
[action] 
Loop 
 
You must be sure to give your loop a way to stop. Otherwise, it will run forever! Three ways 
of doing this are illustrated below: 
 
Do While...Loop 
This kind of loop will run while a condition is true. Note: if the condition is false when the loop 
starts, your action(s) will not run. 
 
Example 
 
'Raise a channel while its value is less than 1000 
Do While NewValue("MyARC", 1) < 1000 

Raise "MyARC", 1 
Loop 
 
Do...Loop Until 
This loop will run until a condition is true. Unlike the previous example, however, it will always 
run at least once. 
 
Example 
 
'Raise a channel until its status is On. 
Do 

Raise "MyARC", 1 
Loop Until NewStatus("MyARC", 1) = True 
 
Exit Do 
You can also stop a loop by including an "Exit Do" statement inside of the loop. 
 
Example 
 
'Raise a channel, but stop the loop if the ARC-16 is disconnected 
Do 

Raise "MyARC", 1 
 
If IsConnected("MyARC") = False Then 

Exit Do 
End If 

Loop 
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Date/Time Functions 
 
VBS includes many functions dealing with date and time. For a complete reference on Date 
and Time functions, visit Microsoft’s online scripting resource at 
http://www.microsoft.com/scripting. Here are just some of these functions:  
 
Using Literal Date/Time 
To use a date or time "literally" in a script, you must begin and end the value with the pound 
sign (#). For example: 
 
#1/1/2002# 
#January 1, 2002# 
#1:00 PM# 
#13:00# 
#1/1/2002 1:00 PM# 
 
Now 
Returns the current date and time. 
 
Example 
 
'Print a message with the current date/time 
Message Now() 
 
Date 
Returns the current date. 
 
Example 
 
'Print a message with current date 
Message Date() 
 
Time 
Returns the current time. 
 
Example 
 
'See if it is after 5:00 
If Time() > #5:00 PM# Then 
... 
End If 
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AutoPilot Script Commands 
 
ARCTime 
 
Description 
Use the ARCTime command to convert the current time to the time zone used by the ARC-
16. If your ARC-16 is in your local time zone, you will not need this command. 
 
For example: if you are in EST, and your ARC-16 is in CST, at 5:00 Eastern ARCTime will 
return 4:00. 
 
Syntax 
ARCTime(ARCName) 
 
Parameters 

Parameter  Description 
ARCName Name of the ARC-16 (use "quotes") 

 
Return 
ARCTime returns a time value. 
 
Example 
 
'See if it is past Sunrise in the ARC's time zone: 
If ARCTime("MyARC") > Sunrise("MyCalendar") Then 
... 
End If 
 
Connect 
 
Description 
Connects to an ARC-16, and optionally to all the other ARCs in that group. 
 
Syntax 
Connect(ARCName, Connection, ConnectAll) 
 
Parameters 

Parameter  Description 
ARCName Name of the ARC-16 to which you want to connect (use quotes). 
Connection (Optional) Name of the connection that you want to use (use quotes). Leave blank 

to use the default connection. 
ConnectAll (Optional) Use True to connect to all the other ARCs in the group; otherwise use 

False. If left blank, True is assumed. 
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Return 
The Connect command will return a message indicating the status of the connection: 
 

• "Connected"  
• "Bad Password"  
• "Incorrect Serial Number"  
• "Busy Signal"  
• "Connection Canceled"  
• "Device Not Found"  
• "Communication Error"  
• "No Answer"  
• "No Dialtone"  
• "No Response From ARC-16"  

 
Example 
 
'Connect to MyARC using MyConnection, and connect all the other ARCs in the group: 
Connect "MyARC", "MyConnection", True 
 
Disconnect 
 
Description 
Disconnects from the ARC-16 specified, as well as all other ARCs in the group. 
 
Syntax 
Disconnect(ARCName) 
 
Parameters 

Parameter  Description 
ARCName Name of the ARC-16 (use quotes). 

 
Example 
 
'Disconnect from MyARC 
Disconnect "MyARC" 
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IsConnected 
 
Description 
Use IsConnected to determine if AutoPilot is already connected to your ARC-16. 
 
Syntax 
IsConnected(ARCName) 
 
Parameters 

Parameter  Description 
ARCName Name of the ARC-16 (use quotes). 

Return 
IsConnected will return True or False. 
 
Example 
 
'If not already connected, run the Connect command 
If Not IsConnected("MyARC") Then 

Connect("MyARC") 
End If 
 
IssueCommand 
 
Description 
Sends a Raise or Lower command to the ARC-16. 
 
Syntax 
IssueCommand(ARCName, Channel, UseRaise, Duration) 
 
Parameters 

Parameter  Description 
ARCName Name of the ARC-16 (use quotes). 
Channel Channel Number 
UseRaise True for Raise, False for Lower. 
Duration (Optional) Duration of the command in seconds (can use decimal). If left blank, 1 

second is used. 
 
Example 
 
'Send a Raise command to MyARC channel 12 for 3 seconds 
IssueCommand "MyARC", 12, True, 3 
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Raise 
 
Description 
Issues the Raise command to the ARC-16. 
 
Syntax 
Raise(ARCName, Channel, Duration) 
 
Parameters 

Parameter  Description 
ARCName Name of the ARC-16 (use quotes). 
Channel Channel Number 
Duration (Optional) Duration of the command in seconds (can use decimal). If left blank, 1 

second is used. 
 
Example 
 
'Raise Channel 1 on MyARC for 2.5 seconds 
Raise "MyARC", 1, 2.5 
 
Lower 
 
Description 
Issues the Lower command to the ARC-16. 
 
Syntax 
Lower(ARCName, Channel, Duration) 
 
Parameters 

Parameter  Description 
ARCName Name of the ARC-16 (use quotes). 
Channel Channel Number 
Duration (Optional) Duration of the command in seconds (can use decimal). If left blank, 1 

second is used. 
 
Example 
 
'Lower Channel 1 on MyARC for 2.5 seconds 
Lower "MyARC", 1, 2.5 
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Status 
 
Description 
Reads the status of a channel on the ARC-16. 
 
Syntax 
Status(ARCName, Channel) 
 
Parameters 

Parameter  Description 
ARCName Name of the ARC-16 (use quotes). 
Channel Channel Number 

 
Return 
The Status command will return True if the channel is on, or False if it is off. 
 
Example 
 
'Issue a lower command if Channel 8 on MyARC is on. 
If Status("MyARC", 8) = True Then 

Lower("MyARC", 8) 
End If 
 
Value 
 
Description 
Returns the analog value of the channel specified. 
 
Syntax 
Value(ARCName, Channel) 
 
Parameters 

Parameter  Description 
ARCName Name of the ARC-16 (use quotes). 
Channel Channel Number 

 
Return 
The Value command will return a number, which can contain a decimal point. 
 
Example 
 
'Issue a raise command to Channel 1 on MyARC if the value is greater than 10.5 
If Value("MyARC", 1) > 10.5 Then 

Raise("MyARC", 1) 
End If 
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NewStatus 
 
Description 
NewStatus is just like Status; only it waits for a new reading from the ARC-16 rather than 
using the last reading received. It may take several seconds for NewStatus to return a value. 
 
Note: NewStatus is best used when you are waiting for the result of another action. For 
example, if you issue a Raise command to turn a channel on, use NewStatus to see if the 
command was successful. 
 
Syntax 
NewStatus(ARCName, Channel) 
 
Parameters 

Parameter  Description 
ARCName Name of the ARC-16 (use quotes). 
Channel Channel Number 

 
Return 
The NewStatus command will wait for a reading from the ARC-16, and then return True if the 
channel is on, or False if it is off. 
 
 
 
Example 
 
'Issue a raise command to turn on Channel 4 on MyARC.  
'Then issue a raise command to channel 5 if it was successful: 
Raise("MyARC", 4) 
If NewStatus("MyARC", 4) = True Then 

Raise("MyARC", 5) 
End If 
 
NewValue 
 
Description 
NewValue is just like Value; only it waits for a new reading from the ARC-16 rather than 
using the last reading received. It may take several seconds for NewValue to return the 
channel's analog value. 
 
Note: NewValue is best used when you are waiting for the result of another action. For 
example, if you issue a Raise command to increase the value of a channel, use NewValue to 
see if the command was successful. 
 
Syntax 
NewValue(ARCName, Channel) 
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Parameters 
Parameter  Description 
ARCName Name of the ARC-16 (use quotes). 
Channel Channel Number 

 
Return 
The NewValue command will return a number, which can contain a decimal point. 
 
Example 
 
'Use a Loop to raise a Channel 1 on MyARC until it is greater than 1000. 
Do Until NewValue("MyARC", 1) > 1000 

Raise("MyARC", 1) 
Loop 
 
PreSunrise 
 
Description 
PreSunrise returns the "Pre-Sunrise" value of a calendar. 
 
Note: all calendar functions will convert the time to your local time zone, and automatically 
adjust for Daylight Saving Time. This is done so that you can compare times without having 
to worry about time zones. 
 
Syntax 
PreSunrise(Calendar) 
 
Parameters 

Parameter  Description 
Calendar Name of the calendar (use quotes). 

 
Return 
Returns a time value, which is converted to your local time zone. 
 
Example 
 
'See if it is after PreSunrise using MyCalendar 
If Now() > PreSunrise("MyCalendar") Then 
... 
End If 
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Sunrise 
 
Description 
Sunrise returns the "Sunrise" value of a calendar. 
 
Note: all calendar functions will convert the time to your local time zone, and automatically 
adjust for Daylight Saving Time. This is done so that you can compare times without having 
to worry about time zones. 
 
Syntax 
Sunrise(Calendar) 
 
Parameters 

Parameter  Description 
Calendar Name of the calendar (use quotes). 

 
Return 
Returns a time value, which is converted to your local time zone. 
 
Example 
 
'See if it is after Sunrise using MyCalendar 
If Now() > Sunrise("MyCalendar") Then 
... 
End If 

 
Sunset 
 
Description 
Sunset returns the "Sunset" value of a calendar. 
 
Note: all calendar functions will convert the time to your local time zone, and automatically 
adjust for Daylight Saving Time. This is done so that you can compare times without having 
to worry about time zones. 
 
Syntax 
Sunset(Calendar) 
 
Parameters 

Parameter  Description 
Calendar Name of the calendar (use quotes). 

 
Return 
Returns a time value, which is converted to your local time zone. 
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Example 
 
'See if it is after Sunset using MyCalendar 
If Now() > Sunset("MyCalendar") Then 
... 
End If 
 
PostSunset 
 
Description 
PostSunset returns the "Post Sunset" value of a calendar. 
 
Note: all calendar functions will convert the time to your local time zone, and automatically 
adjust for Daylight Saving Time. This is done so that you can compare times without having 
to worry about time zones. 
 
Syntax 
PostSunset(Calendar) 
 
Parameters 

Parameter  Description 
Calendar Name of the calendar (use quotes). 

 
Return 
Returns a time value, which is converted to your local time zone. 
 
Example 
 
'See if it is after PostSunset using MyCalendar 
If Now() > PostSunset("MyCalendar") Then 
... 
End If 
 
User1 
 
Description 
User1 returns the "User 1" value of a calendar. 
 
Note: all calendar functions will convert the time to your local time zone, and automatically 
adjust for Daylight Saving Time. This is done so that you can compare times without having 
to worry about time zones. 
 
Syntax 
User1(Calendar) 
 
Parameters 

Parameter  Description 
Calendar Name of the calendar (use quotes). 
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Return 
Returns a time value, which is converted to your local time zone. 
 
Example 
 
'See if it is after User 1 time using MyCalendar 
If Now() > User1("MyCalendar") Then 
... 
End If 
 
User2 
 
Description 
User1 returns the "User 2" value of a calendar. 
 
Note: all calendar functions will convert the time to your local time zone, and automatically 
adjust for Daylight Saving Time. This is done so that you can compare times without having 
to worry about time zones. 
 
Syntax 
User2(Calendar) 
 
Parameters 

Parameter  Description 
Calendar Name of the calendar (use quotes). 

Return 
Returns a time value, which is converted to your local time zone. 
 
Example 
 
'See if it is after User 2 time using MyCalendar 
If Now() > User2("MyCalendar") Then 
... 
End If 
 
GetScriptStatus 
 
Description 
Returns the status of a script. 
 
Syntax 
GetScriptStatus(Script) 
 
Parameters 

Parameter  Description 
Script Name of the Script (use quotes). 

 



AutoPilot® 2 Instruction Manual  60 

 
 

TECHNICAL SUPPORT: 978-486-0086 • support@burk.com • www.burk.com 
 

Return 
GetScriptStatus will return one of the following statuses: 

• "Off"  
• "Running"  
• "Scheduled"  
• "Looping"  
• "Paused"  
• "DataWait"  
• "Connecting"  

 
Example 
 
'If the script MyScript is off, run it" 
If GetScriptStatus("MyScript") = "Off" Then 

RunScript "MyScript" 
End If 
 
RunScript 
 
Description 
Runs a script. 
 
Syntax 
RunScript(Script) 
 
 
Parameters 

Parameter  Description 
Script Name of the Script (use quotes). 

 
Example 
 
'Run MyScript 
RunScript "MyScript" 
 
StopScript 
 
Description 
Immediately stops a running script. Note: if the script is looping, you must use 
UnScheduleScript to prevent it from running again. 
 
Syntax 
StopScript(Script) 
 
Parameters 

Parameter  Description 
Script Name of the Script (use quotes). 
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Example 
 
'Stop MyScript 
StopScript "MyScript" 
 
UnScheduleScript 
 
Description 
Changes the script's schedule to "Idle." Use this on a script that is looping to prevent it from 
running again. Note: UnScheduleScript will not actually stop a script. Use the StopScript 
command to stop the script immediately. 
 
Syntax 
UnScheduleScript(Script) 
 
Parameters 

Parameter  Description 
Script Name of the Script (use quotes). 

 
Example 
 
'UnSchedule MyScript 
UnScheduleScript "MyScript" 

 
Wait 
 
Description 
Pauses the script for the specified number of milliseconds. 
 
Syntax 
Wait(Duration) 
 
Parameters 

Parameter  Description 
Duration Number of milliseconds to wait. 

 
Example 
 
'Issue two commands, spaced 2 seconds apart 
Raise "MyARC", 1 
Wait 2000 
Raise "MyARC", 2 
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Message 
 
Description 
Records the specified message in the Event Log as a Script Message. 
 
Syntax 
Message(Text) 
 
Parameters 

Parameter  Description 
Text Text of the message (use quotes). 

 
Example 
 
'Write the message "Hello": 
Message "Hello" 
 
'Write the status of Channel 1 on MyARC: 
Message Status("MyARC", 1) 
 
'Write the value of Channel 1 on MyARC and add "volts" to the message 
'(This message will appear as "1000 volts"): 
Message Value("MyARC", 1) & " volts" 

 
TakeLog 
 
Description 
Takes a log on the specified ARC-16. 
 
Syntax 
TakeLog(ARCName) 
 
Parameters 

Parameter  Description 
ARCName Name of the ARC-16 (use quotes). 

 
Example 
 
'Take a log on MyARC 
TakeLog "MyARC" 
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EndScript 
 
Description 
EndScript can be used to immediately stop the script. 
 
Note: you do not always need to use EndScript; scripts will stop when the last line of code is 
executed. You only need to use EndScript to stop before the last line of code. 
 
Syntax 
EndScript 
 
Example 
 
'End the script if MyARC is not connected: 
If Not IsConnected("MyARC") Then 

EndScript 
End If 
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Reports 
 
There are two ways to view your logged data in AutoPilot: you can view a report, or export 
the data. Both are described in the following sections.  
  
Using the Report Writer 
 
To open the Report Writer, click "Print Report..." from the File menu in AutoPilot. The report 
writer has several tabs that are described below. 
 
Report Writer: General 
 

 
 
Date Range 
Click the From and/or To check box to limit the report to a date range. Use the calendar drop 
down to pick dates. You can sort your report in either ascending or descending order. 
 
Paper Orientation 
The report is designed for 8.5" x 11" paper and is printable in portrait or landscape mode. 
Landscape mode allows you to include more analog channels in the report.  
 
Time Zones 
If you are including data from other time zones in your report, you need to consider how to 
handle the time values. If all of your data is from the same time zone, just leave this set to 
"Leave times in remote time zones." 
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There are three ways to sort time zones: 
 

Sort Method Description 
Leave in remote time zones; 
Sort chronologically 

Time values will be left in their original time zones. Records will be sorted 
chronologically. This means that some values may appear to be out of order. If 
you have one ARC-16 in Eastern Time, another in Pacific Time, and are sorting 
in ascending order: 2:01 PST will appear after 5:00 EST 

Leave in remote time zones; 
Sort literally 

Time values will be left in their original time zones. Records will be sorted 
literally. This means that some of your records will be out of order, but the  
time values will appear in numerical order. For example, if sorting in ascending 
order: 3:00 EST will appear after 2:00 PST, even though 3:00 EST is earlier 
than 2:00 PST. 

Convert times to local time 
zone 

All time values will be converted to whatever your local time zone is. If you're  
in Eastern Time, AutoPilot will add three hours to values from a Pacific Time  
site. Note that the time calculation takes into account Daylight Saving Time. 
This means that records logged before DST will be printed as if they had been 
logged during DST (values from the fall will be increased by one hour). If your 
report will include both Standard and DST times, you may want to use one of 
the other sorting options. 

 
Report Writer: Telemetry 
 

 
 
If you want to include analog readings in your report, first select the number of channels that 
you want to include. The number of channels available is determined by the paper orientation 
(see General tab). 
 
For each column, choose the ARC-16 and analog channel. You are not limited to one ARC-
16 per report - you may include channels from as many ARC-16s as you like. Note: you 
cannot use the same channel from the same ARC-16 twice. 
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Report Writer: Status Channels 
 

 
 
About Status Logs... 
AutoPilot records status channels in two ways. When an ARC-16 is logged, AutoPilot records 
the values of all the status channels. Also, when the status of a channel changes, AutoPilot 
records the change in the Status Changes log. 
 
This section of the Report Writer allows you to include logged status - status changes are 
part of the Other Fields tab. 
 
Adding Status Channels 
If you want to include Logged Status, choose the ARC-16 from the drop down list, select the 
desired channel from the "Select a status channel" list, and click Add. You may add as many 
status channels from as many ARCs as you like. Note: use the Add All button to add all the 
status channels from the selected ARC-16. 
 
Removing Status Channels 
To remove a status channel from the report, select it in the bottom list and click Remove. Use 
Remove All to remove all status channels from the report. 
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Report Writer: Other Fields 
 

 
 
Status Changes 
To add status changes to your report, click on the check box next to the desired ARC-16(s) 
in the Status Changes list. 
 
Note: the Status Changes log indicates a change in status. To include status channels that 
are logged along with analog values, see the Status Channels tab. 
 
Alarms 
If you want to include alarms in your report, click the check box next to the desired ARC-
16(s) in the Alarms list. 
 
Events 
To include events in your report, click the check box next to each of the type of events that 
you want to include. Note: when you click on an event type, a description of that type will 
appear in the area to the right of the list. 
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Report Writer: Header 
 

 
 
Report Header 
The report header will appear at the top of the report, before the page header. 
 
Report Title 
Enter a title for your report. The title will appear in large letters at the top of the header. 
 
Print Date Range 
Check this box to print the range of dates included in the report. Note: the date range is 
determined by the records that are actually included in the report, not just by the date range 
you entered in the General tab. 
 
Print Time Zone Information 
Check this box to print a description of how time zones are handled in the report (as you 
specified in the General tab). 
 
Additional Text 
Add any additional text that you want to include in the report header. You can add as many 
lines of text as you like. 
 
Page Header 
The page header will appear at the top of each page in the report. 
 
Site Name 
Check this box to print the name of the ARC-16 for each analog value included in the report. 
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Channel Name 
Check this box to print the channel name for each analog value. 
 
Analog Value Units 
Check this box to print the units label for each analog value. 
 
Additional Text 
Add any additional text that you want to include in the page header. You can add as many 
lines of text as you like. 
 
Report Writer: Footer 
 

 
 
Report Footer 
The report footer will appear on the last page of the report, above the page footer. 
 
Additional Text 
Add any additional text that you want to include in the report footer. You can add as many 
lines of text as you like. 
 
Page Footer 
The page footer will appear at the bottom of every page in the report. 
 
Print Today's Date 
Check this box to print today's date in the footer. 
 
Page Number 
Check this box to print the page number in the footer. 
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Additional Text 
Add any additional text that you want to include in the page footer. You can add as many 
lines of text as you like. 
 
Saving and Printing Reports 
 
Saving Reports 
If you are going to reuse this report in the future, you can save the template. To do this, click 
"Save..." on the Report Writer's File menu. You will be prompted to choose a file name. 
 
Note: you are saving the template (the layout of the report), but not the actual data included 
in the report. This allows you to print a similar report in the future, but always with current 
data. 
 
Opening Saved Reports 
To load a previously saved template, click "Open..." from the File menu in the Report Writer. 
You will be prompted to pick a template file. Select the file you want to use and click Open. 
All of the settings that you saved with this template will be loaded into the Report Writer. 
 
Printing 
To preview your report, click "Print Preview..." from the File menu. You will see a progress 
dialog while your report is generated. Note: it may take up to several minutes to generate a 
lengthy report, depending on the speed of your computer. You can then print from the 
preview window. The Export icon from in print preview toolbar allows you to export the report 
data in HTML (.html) and text (.txt) formats. To export in Comma Separated Value (.csv) 
format, use the Export Data function from the File menu (see the next section). 
 
If you do not need to preview the report, click "Print..." from the File menu. You will see the 
progress dialog and then be prompted to choose a printer. 
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Exporting Data 
 
You can export your alarm history, event log, status changes, and telemetry to a comma 
separated value (CSV) file. CSV files can be opened in many applications, including 
Microsoft Excel and Access. 
 
To export, click "Export Data..." from the File menu in AutoPilot. 
 

 
 
Select the table that you want to export from the drop down list, and click Export. You can 
specify a range of dates to include, and limit the export to a particular ARC-16. Click "Export" 
to continue. You will be prompted for a file name. Note: the export may take several minutes, 
depending on the speed of your computer and how much data you have logged. 
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Glossary 
 

Term Description 
Alarm There are three kinds of alarms: high, low, and status. A high or low alarm occurs when an 

analog channel is above or below the limits set on the ARC-16 (Limits Monitoring must be 
turned on). A status alarm occurs when the status of a channel is ON, and the status alarm 
is enabled for that channel. 

Authorization 
Code 

An Authorization Code is required to use an ARC-16 with AutoPilot. Codes are issued by 
Burk Technology, and included on the registration sheet sent with your order. If you need a 
replacement copy, please contact Burk Technology. Authorization codes are specific to your 
Serial Number and Program Key.  

Calendar An AutoPilot Calendar consists of 6 user-defined times for each month. The times are Pre-
Sunrise, Sunrise, Sunset, Post Sunset, User 1, and User 2. Times are always in Standard 
Time. 

Connection A connection is the link between your computer and the ARC-16. A connection can use 
either a COM Port or a Modem. When you connect to an ARC, AutoPilot can communicate 
with all of the units that are linked to that ARC-16 (the other units in the group). 

Default 
Connection 

If a connection is defined as the default for the group, AutoPilot will use that connection 
without first prompting you to choose from a list of connections. If you only have one 
connection in a group, it is a good idea to set it as the default. 

Group A group can comprise between one and four ARC-16s, each connected to each other. When 
ARCs are grouped, AutoPilot can communicate with the whole group when the computer is 
connected to just one of the ARCs. 

Idle Script A script is idle when it is not running and not waiting for anything (such as a scheduled run 
time or interval, etc). 

Maintenance 
Mode 

The ARC-16 can be put into Maintenance Mode (Maint Mode) by pressing the Maint button 
on the front panel. When in Maint Mode, you will not be able to issue commands (raise and 
lower) to the ARC-16 from the computer. 

Program Key The Program Key is issued by Burk Technology when you purchase AutoPilot 2. You will 
need a program key to install the software and add ARC-16s. AutoPilot 2 ships with a 
registration sheet containing your program key and authorization codes. If you need a 
replacement copy, please contact Burk Technology. 

Script An AutoPilot Script lets you automate AutoPilot and your ARC-16(s). AutoPilot Script is 
based on Visual BASIC Script (VBS), and includes a library of commands specific to 
AutoPilot. 

Site Letter Every ARC-16 is assigned a site letter (A, B, C, or D) when it is first configured. This 
identifies the ARC-16 uniquely when it is connected to other units in a group. 

User User accounts in AutoPilot allow you to grant only certain privileges to individuals. 
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Appendix A: 
Null Modem Cable Pinouts 

For Direct Serial Connection 
 

Computer 
(DB25) 

 CI-16 (DB25)

PGND 1  1 PGND
RxD 3  2 TxD
TxD 2  3 RxD
CTS 5  4 RTS
RTS 4  5 CTS
GND 7  7 GND
CD 8  20 DTR
Jumper pin 20 to pin 6 on computer 
side 

 
Computer 

(DB9) 
 CI-16 (DB25)

RxD 2  2 TxD
TxD 3  3 RxD
GND 5  7 GND
RTS 7  5 CTS
CTS 8  4 RTS

Computer 
(DB25) 

 ESI (DB9) 

TxD 2  2 RxD
RxD 3  3 TxD
CTS 5  7 RTS
GND 7  5 GND
    

Computer 
(DB9) 

 ESI (DB9) 

RxD 2  3 TxD
TxD 3  2 RxD
GND 5  5 GND
CTS 8  7 RTS

 
 


